Hi,

> "chmod 655 <dir name>"

Shouldn't it be "755"? Otherwise the user is not allowed to list the
content of the directory which will definitely cause an error.

The user running Nutch is required to have "rwx" permissions in the
"crawldb" folder and all its subfolders.


> <http://lucene.472066.n3.nabble.com/file/t494657/nutch_error2.png>

According to the error message in the screenshot, you first need to remove
the file crawl/crawldb/.locked

Injector: java.io.IOException: lock file crawl/crawldb/.locked already exists.
        at org.apache.nutch.util.LockUtil.createLockFile(LockUtil.java:51)
        at org.apache.nutch.util.LockUtil.createLockFile(LockUtil.java:81)
        at org.apache.nutch.crawl.CrawlDb.lock(CrawlDb.java:199)
        at org.apache.nutch.crawl.Injector.inject(Injector.java:400)
        at org.apache.nutch.crawl.Injector.run(Injector.java:570)
        at org.apache.hadoop.util.ToolRunner.run(ToolRunner.java:70)
        at org.apache.nutch.crawl.Injector.main(Injector.java:535)

Of course, this is probably because another error happened before.
Could you delete the lock file, try again and share the logs of
this run?

Thanks,
Sebastian

On 2/20/19 8:40 PM, caesium wrote:
> I'm getting an error when trying to use nutch doing the command ./nutch
> inject crawldir/crawldb urls. Based on "(null) entry in command string: null
> chmod 0644" part of error message, thought it was permissions problem,and
> tried setting the permissions for both the urls folder and crawldir to 655
> with the "chmod 655 <dir name>" command. Also tried setting all permissions
> for all groups on both folders with "chmod uog+rwx urls", but still no
> change in error message. Folder permissions in the windows UI, even if I
> uncheck the read only black block it'll just go right back to being checked,
> so I'm not able to change that, which is weird. I tried deleting and
> recreating the folders but that didn't do any good either. 
> 
> <http://lucene.472066.n3.nabble.com/file/t494657/nutch_error2.png> 
> <http://lucene.472066.n3.nabble.com/file/t494657/permissions1.png> 
> 
> Anyone have any idea what could be causing this?
> 
> 
> 
> --
> Sent from: http://lucene.472066.n3.nabble.com/Nutch-User-f603147.html
> 

Reply via email to