Hello

I got it working. For the time being, I opened :

iptables -A INPUT -p udp -m udp --dport 3478 -j ACCEPT
iptables -A OUTPUT -p udp -m udp --sport 3478 -j ACCEPT

Thanks
     On Wednesday, March 25, 2020, 11:04:24 AM EDT, Marcus Schulz 
<m...@polarnetworks.de> wrote:  
 
 Hi,
that's what I wrote yesterday to another thread with that problem. It may help 
you.I finally got it working, but without vpn.
Kind regards
Marcus

Hi,
I just subscribed to this list. I had the same problems and managed to get it 
works after tweo nights. I needed it also for a virtual classroom (who does not 
at the moemnt?? ) and for office.Please don't blame me, if i did not follow 
some rules here at the moment.I just want to help.
My set up: ubuntu 18.04 lts image at a Strato VServer. OpenMeeting M3.
First steps:I took the installation guide for ubuntu I found at the open 
meetings project site. Worked like a charm.Then I saw green bars when someone 
spoke, but no sound and no video except my own.
first i had to run kurento not as user nobody as decribed, but I used default 
kurento. Otherwise there where exceptions cause home folder is "/nonexistent" 
and gstreamer caches failed to work.Not sure if it's important, but I fixed it 
for me. My openmeeting installation runs with user kurento also. Just change it 
in the /etc/init.d/tomcat3 skript and chown -R kurento /opt/open503 of 
course.When the compilation of ffmpeg that is made by the skript provided 
fails, just install the missing dev packages. Don't remeber all. But's that's 
easy to find out, because "make " complains about.
Then I saw in the logs that connection to kurento server fails for web sockets.
I read in the net and found that a turnserver is needed, when clients accessing 
kurento are located behind NAT. Guess almsot every home dial has such a setup, 
so I did it.If I am wrong with it, and that's only needed, If openmeetings is 
behind NAT, please tell me. Than I remove it again.
if needed:
apt-get install coturn
vi /etc/turnserver.conf
configure 
this:realm=kurento.orguser=kurento:somepasslog-file=/var/log/turnserver/turnserver.log
I think that has been all.


Then:
vi 
/etc/kurento/modules/kurento/WebRtcEndpoint.conf.iniedit:turnURL=kurento:somepass@<your-public-IP>:3478
restart everything.
Than didn't work very much better also, so I took a look at iptables log file.
I added this rules:
iptables -A INPUT -p udp -m udp  --dport 10000:65535 -j ACCEPTiptables -A 
OUTPUT -p udp -m udp  --sport 10000:65535 -j ACCEPTiptables -A INPUT -p udp -m 
udp --dport 3478 -j ACCEPTiptables -A OUTPUT -p udp -m udp --sport 3478 -j 
ACCEPT
Now it works for me.
There is may be missing something or useless. But finally I got a working 
solution.I am no WebRTC expert... just a JEE Developer with loves Linux for 
years :)
Any suggestions or hints if somhing is wrong or useless are welcome.
Kind regards
Marcus

Am Mittwoch, den 25.03.2020, 14:55 +0000 schrieb Benteftifa, Hafed:
Hello,
It seems I am having the same problems as others regarding audio and video.
Here is the setup (Ubuntu 18) after following Alvaro's instructions:
Setup 1: VM on vpsserver  worked correctly. While users had the https not safe 
message when using the IP address for the room, we were able to go through the 
conference with audio and video. This is a backup solutions for us.
Setup 2: VM on our internal network. Access is through a VPN from the outside. 
While users had the https not safe message when using the IP address for the 
room, we were able to go through the conference with audio and video. 
Unfortunately, a lot of jitters and random freeze and booting out of some users 
occured. I believe this is due to the internal cloud server we used. We will 
not be using this solution (too difficult for some users to setup their vpn).
Setup 3: We have a VM instance on Microsoft azure. While users had the https 
not safe message when using the IP address for the room, everybody was able to 
access the room and see his/her own camera and see the microphone working. 
However, the rest of us were not able to hear audio and video from the others. 
After spending hours on the mailing list, it boils down to us not using a TURN 
server.
I found this link on the mailing list (see post by René Sholtz):  
https://markmail.org/message/3dgy62lj3m74mogy#query:+page:1+mid:3dgy62lj3m74mogy+state:results

These are the instructions for configuring a TURN server (coturn). Since we are 
using an IP address, did anyone have success in making those configuration 
steps. Maybe Alvaro has written a setup manual for this part?
Thanks
  

Reply via email to