We are upgrading apache poi from 3.7 to 4.1.1. We tried 4.0.0 it was giving
same issue. 
We are generating a simple vanilla excel file. Which the 3.7 generates fine
on local and server. We upgraded to newer version and the file is generating
with some minor changes in styles viz borders, fonts etc is generating fine
in local. While the same file is not generating on the server. I tried
unzipping the xlsx and found the worksheet is generated fine with styles and
app xml. 
Though core.xml, content_types.xml and rels files are empty. And by empty I
mean 0bytes empty. The files are created but nothing in them. This is not
the case in local and file is generating fine. 

I upgraded the dependencies eg xmlbeans to proper version 3.0.1 for 4.0.0
and 3.1.0 for 4.1.1 but the issue persists in server only. 

The xlsx file is generating , but shows corrupt , guessing due to lack of
required core and content_types xmls and rels file. Though no error or
exception is logged

We are using ibm websphere 8.5 in the server and corresponding java run
time. I couldn't enable logging in the server as we are using log4j and the
log4j config was in xml format and couldn't find how to do to it in xml

Some direction or help will be much appreciated


Sent from: http://apache-poi.1045710.n5.nabble.com/POI-User-f2280730.html

To unsubscribe, e-mail: user-unsubscr...@poi.apache.org
For additional commands, e-mail: user-h...@poi.apache.org

Reply via email to