I just tried and it was able to compile using mvn clean install -DskipTests -P 
'native,include-shaded-deps,!externals,!examples,!coverage’

[INFO] ------------------------------------------------------------------------
[INFO] Reactor Summary for Storm 2.0.0:
[INFO]
[INFO] Storm .............................................. SUCCESS [ 30.905 s]
[INFO] Apache Storm - Checkstyle .......................... SUCCESS [  2.093 s]
[INFO] multilang-javascript ............................... SUCCESS [  0.262 s]
[INFO] multilang-python ................................... SUCCESS [  0.100 s]
[INFO] multilang-ruby ..................................... SUCCESS [  0.122 s]
[INFO] maven-shade-clojure-transformer .................... SUCCESS [  6.181 s]
[INFO] storm-maven-plugins ................................ SUCCESS [  5.707 s]
[INFO] Shaded Deps for Storm Client ....................... SUCCESS [  9.584 s]
[INFO] Storm Client ....................................... SUCCESS [ 41.827 s]
[INFO] storm-server ....................................... SUCCESS [ 12.527 s]
[INFO] storm-clojure ...................................... SUCCESS [  6.936 s]
[INFO] Storm Core ......................................... SUCCESS [ 14.464 s]
[INFO] Storm Webapp ....................................... SUCCESS [ 10.393 s]
[INFO] storm-clojure-test ................................. SUCCESS [  5.490 s]
[INFO] storm-submit-tools ................................. SUCCESS [  1.451 s]
[INFO] ------------------------------------------------------------------------
[INFO] BUILD SUCCESS
[INFO] ------------------------------------------------------------------------
[INFO] Total time:  02:32 min
[INFO] Finished at: 2019-08-16T04:44:33Z
[INFO] ————————————————————————————————————


Not sure what happened to your build. Maybe others have some idea about it.

> On Aug 15, 2019, at 8:58 PM, Kang Minwoo <minwoo.k...@outlook.com> wrote:
> 
> Hello,
> 
> I try to compile storm 2.0.0 from source.
> But I had an error. that is "class file for 
> org.apache.yetus.audience.InterfaceAudience not found"
> 
> I don't know why maven occur compilation error.
> 
> Build command: mvn clean install -DskipTests -P 
> 'native,include-shaded-deps,!externals,!examples,!coverage'
> Java version: 1.8.0_202
> Maven version: 3.6.1
> 
> 
> -----
> 
> [INFO] 
> ------------------------------------------------------------------------
> [INFO] Reactor Summary for Storm 2.0.0:
> [INFO]
> [INFO] Storm .............................................. SUCCESS [  2.716 
> s]
> [INFO] Apache Storm - Checkstyle .......................... SUCCESS [  0.542 
> s]
> [INFO] multilang-javascript ............................... SUCCESS [  0.082 
> s]
> [INFO] multilang-python ................................... SUCCESS [  0.087 
> s]
> [INFO] multilang-ruby ..................................... SUCCESS [  0.076 
> s]
> [INFO] maven-shade-clojure-transformer .................... SUCCESS [  2.276 
> s]
> [INFO] storm-maven-plugins ................................ SUCCESS [  2.877 
> s]
> [INFO] Shaded Deps for Storm Client ....................... SUCCESS [  7.925 
> s]
> [INFO] Storm Client ....................................... SUCCESS [ 25.205 
> s]
> [INFO] storm-server ....................................... SUCCESS [  8.549 
> s]
> [INFO] storm-clojure ...................................... SUCCESS [  4.844 
> s]
> [INFO] Storm Core ......................................... FAILURE [  2.730 
> s]
> [INFO] Storm Webapp ....................................... SKIPPED
> [INFO] storm-clojure-test ................................. SKIPPED
> [INFO] storm-submit-tools ................................. SKIPPED
> [INFO] 
> ------------------------------------------------------------------------
> [INFO] BUILD FAILURE
> [INFO] 
> ------------------------------------------------------------------------
> [INFO] Total time:  58.980 s
> [INFO] Finished at: 2019-08-16T10:46:03+09:00
> [INFO] 
> ------------------------------------------------------------------------
> [ERROR] Failed to execute goal 
> org.apache.maven.plugins:maven-compiler-plugin:3.7.0:compile 
> (default-compile) on project storm-core: Compilation failure
> [ERROR] cannot access org.apache.yetus.audience.InterfaceAudience
> [ERROR]   class file for org.apache.yetus.audience.InterfaceAudience not found
> 
> -----
> 
> Best regards,
> Minwoo Kang

Reply via email to