Hi Richard,

On Mon, 24 Jul 2023 at 01:40:52PM +0200, Richard Rosner wrote:

My biggest problem with the old installation was (which was set up
before I became admin and I can't tell if it has been upgraded somehow
from SOGo 2.x, which we where using before 5.x, or if it was a fresh
install) that when I took over, the whole config was commented out and
everything was set to their default values. I have no idea how it even
worked in the first place, already because the default database is
postgresql, which isn't even installed on the system. And when I tried
to edit things like page title or availability of forwarding, they
simply didn't get applied. So I hoped with reinstalling I could solve
the issue. I even did an apt purge to remove everything from that old
installation (so only the mysql database survived), but obviously the
problem seems to be somewhere it did survive.

On Mon, 24 Jul 2023 at 03:27:49PM +0200, Richard Rosner wrote:

The old installation was SOGo (up until 5.8.0) on Debian 11 from the official Nightly Repo. I now switched to Debians own packages after upgrading to Debian 12, so it's still SOGo 5.8.0. But as the problem was present during the whole 5.x cycle (at least since we switched from 2.x, maybe in 2018 or so) and I switched to the Debian packages just now, it must be a problem independent of the package source.

just another idea regarding this strange behaviour:

Within /usr/share/doc/sogo/README.Debian

"The SOGo debian package differs from upstream in placing the
configuration file in /etc/sogo/sogo.conf instead of using the GNUstep
user defaults that are placed under the home directory of the user
used to run SOGo. This file is parsed as GNUstep defaults in the
"sogod" domain, which means you must not specify the sogod domain in
the configuration file (there shouldn't be a "sogod = {" in

Within a non-Debian sogo.conf there's this hint:

* ~sogo/GNUstep/Defaults/.GNUstepDefaults has precedence over this file, *
* make sure to move it away to avoid unwanted parameter overrides.       *

--> Maybe you still have a mixture of old Debian and non-Debian and/or 2.x vs. 5.x configuration files somewhere? Could you have a look at /var/lib/sogo/GNUstep/Defaults/ if there are files which could provide SOGo defaults even if you delete /etc/sogo/sogo.conf. Or somewhere else, perhaps grepping for some relevant content shows a hit?

And just to be sure: in /etc/passwd is there an entry for the sogo user like 
this one?:

sogo:x:999:999:SOGo daemon:/var/lib/sogo:/usr/sbin/nologin

The home directory would be the interesting part.


Reply via email to