求助,谢谢 配置完网络,安装了cloud-agent,但无法正常启动。
[root@kvm-1 ~]# service cloud-agent status cloud-agent dead but subsys locked log如下: 2013-04-05 08:11:37,611 INFO [utils.component.ComponentLocator] (main:null) Unable to find components.xml 2013-04-05 08:11:37,637 INFO [utils.component.ComponentLocator] (main:null) Skipping configuration using components.xml 2013-04-05 08:11:37,638 INFO [cloud.agent.AgentShell] (main:null) Implementation Version is 4.0.0.20121024012150 2013-04-05 08:11:37,638 INFO [cloud.agent.AgentShell] (main:null) agent.properties found at /etc/cloud/agent/agent.properties 2013-04-05 08:11:37,640 INFO [cloud.agent.AgentShell] (main:null) Defaulting to using properties file for storage 2013-04-05 08:11:37,646 INFO [cloud.agent.AgentShell] (main:null) Defaulting to the constant time backoff algorithm 2013-04-05 08:11:37,988 INFO [cloud.agent.Agent] (main:null) id is 2013-04-05 08:11:38,012 ERROR [cloud.resource.ServerResourceBase] (main:null) Nics are not configured! 2013-04-05 08:11:38,023 INFO [cloud.resource.ServerResourceBase] (main:null) Designating private to be nic eth0 2013-04-05 08:11:38,197 INFO [resource.virtualnetwork.VirtualRoutingResource] (main:null) VirtualRoutingResource _scriptDir to use: scripts/network/domr/kvm 2013-04-05 08:11:39,405 ERROR [cloud.agent.AgentShell] (main:null) Unable to start agent: Failed to get private nic name
