Hi, 

did you manage to make thread dump of broker? I suspect that broker will send 
response packet for this message after all messages from queue are removed. 
This might take more than 30s if there are lots of messages. Thread dump would 
show what the broker is doing and if it's really so. 

Thanks,
Mirek

----- Original Message -----
> From: "vishal3007" <vishal3...@gmail.com>
> To: users@activemq.apache.org
> Sent: Tuesday, March 13, 2018 10:10:49 AM
> Subject: Artemis: AMQ119014: Timed out after waiting 30,000 ms for response 
> when sending packet 71
> 
> I am trying to remove the messages from 1 or my queue and occasionally I am
> getting the timeout error:
> 
> ERROR: global.search.data.load - AMQ119014: Timed out after waiting 30,000
> ms for response when sending packet 71
> javax.jms.JMSException: AMQ119014: Timed out after waiting 30,000 ms for
> response when sending packet 71
>       at
> org.apache.activemq.artemis.core.protocol.core.impl.ChannelImpl.sendBlocking(ChannelImpl.java:399)
>       at  config.xml
> <http://activemq.2283324.n4.nabble.com/file/t378326/config.xml>
> org.apache.activemq.artemis.core.protocol.core.impl.ChannelImpl.sendBlocking(ChannelImpl.java:318)
>       at
> org.apache.activemq.artemis.core.protocol.core.impl.ActiveMQSessionContext.sendFullMessage(ActiveMQSessionContext.java:418)
>       at
> org.apache.activemq.artemis.core.client.impl.ClientProducerImpl.sendRegularMessage(ClientProducerImpl.java:287)
>       at
> org.apache.activemq.artemis.core.client.impl.ClientProducerImpl.doSend(ClientProducerImpl.java:263)
>       at
> org.apache.activemq.artemis.core.client.impl.ClientProducerImpl.send(ClientProducerImpl.java:126)
>       at
> org.apache.activemq.artemis.jms.client.ActiveMQMessageProducer.doSendx(ActiveMQMessageProducer.java:491)
>       at
> org.apache.activemq.artemis.jms.client.ActiveMQMessageProducer.send(ActiveMQMessageProducer.java:189)
>       at javax.jms.QueueRequestor.request(QueueRequestor.java:54)
> 
> Does anybody has any idea what can be wrong? I have attached my broker
> config file.
> 
> Note:
> 1. My Artemis version is 1.5.3
> 2. There are no messages in the queue and also CPU load is around 30%
> 3. I am using Embedded Artemis server using as Spring beans.
> 
> 
> 
> --
> Sent from: http://activemq.2283324.n4.nabble.com/ActiveMQ-User-f2341805.html
> 

Reply via email to