accountExpired seems to make more sense than accountNotExpired. If you
want to use the later, isExpired=false seemes to make more sense.
Matt
On Fri, Sep 12, 2008 at 2:30 AM, Gordian Yuan <[EMAIL PROTECTED]> wrote:
> hi all,
> i read the appfuse source and i have some doubt in org.appfuse.model.User
>
> @Column(name="account_expired",nullable=false)
> public boolean isAccountExpired() {
> return accountExpired;
> }
>
> @Transient
> public boolean isAccountNonExpired() {
> return !isAccountExpired();
> }
>
> i try to modify it become
>
> @Column(name = "account_non_expired", nullable = false)
> public boolean isAccountNonExpired() {
> return accountNonExpired;
> }
>
> and run "mvn install"
> everything is ok
> for any reason why not dicect use isAccountNonExpired()?
> i'm afraid not just handy to use.
> i think have some other reason for it ? right ?
> Who can give me an answer ` ?
> Thanks in advance
>
---------------------------------------------------------------------
To unsubscribe, e-mail: [EMAIL PROTECTED]
For additional commands, e-mail: [EMAIL PROTECTED]