What Camel version are you using?
And have you tried with a newer version?

Also its easy to try another rest component such as jetty or
netty4-http etc instead of restlet just to see if you can access on
that port then.

But the other suggestions about firewall and network is a very good
start to look also.

On Fri, Oct 14, 2016 at 2:59 PM, ganga_camel <ganga...@gmail.com> wrote:
> Hi,I have a camel route with Rest DSL using the restlet component,
> configuration as listed
> belowrestConfiguration().component("restlet").host("{{hostname}}").port("{{port}}")
> .dataFormatProperty("prettyPrint", "true");
> rest("/books").consumes(MediaType.ALL.toString())
> .produces(MediaType.ALL.toString())
> .post().to("direct:ProcessData");When I run the camel service on my local
> machine with port as anything other than 8080(eg: 9091, 8081 etc....), I am
> able successfully post to the Rest API.However, when I deploy the rest API
> code on the remote server to listen on port 9091 or 8081 etc... (anything
> other than port 8080), I am unable to post to the rest API. But am able to
> successfully post to rest API deployed on remote server when the port is set
> to 8080.This behavior is observed only when the rest API is deployed on
> remote host but works fine with any port number when rest API is running on
> the local machine.Any suggestions would be highly appreciated.Thanks,Ganga
> --
> View this message in context: 
> http://camel.465427.n5.nabble.com/Rest-DSL-with-restlet-Component-unable-to-access-API-when-hosted-on-remote-server-tp5788789.html
> Sent from the Camel - Users mailing list archive at Nabble.com.

Claus Ibsen
http://davsclaus.com @davsclaus
Camel in Action 2: https://www.manning.com/ibsen2

Reply via email to