Apache Cocoon 2.1.13 Released
-----------------------------

   The Apache Cocoon Community is proud to announce the new release
   of Apache Cocoon.



  Apache Cocoon is a web development framework built around the concept
  of separation of concerns (that is: allowing people to do their job
  without having to step on each other toes) and component-oriented web
  RAD.



  Cocoon implements these concepts around the notion of 'component
  pipelines' modelled after the 'process chain' concept where each
  worker specializes on a particular operation. This makes it possible
  to use a Lego(tm)-like approach in building web solutions where
  these components can be hooked together into pipelines without
  requiring further programming.



  We like to think at Cocoon as "web glue" for your web application
  development needs. But most important, a glue that can keep
  concerns separate and allow parallel evolution of the two sides,
  improving development pace and reducing the chance of conflicts.



For more information about Apache Cocoon 2.1.13, please go to
http://cocoon.apache.org

Changes with Apache Cocoon 2.1.13

*) Starting with 2.1.13 the minimum required Java version will be 1.6. [all]

*) Cannot start Cocoon 2.1.12 on Windows [FC]

*) Cannot build with Java 7 [FC]

*) Use ImageIO instead of old com.sun.image.* package in ImageReader [FC]

*) Apache license at the beginning cocoon's dojo widgets templates causes: dojo.widget.Parse: error: [FC]

*) XSP not working with Java 8 [FC]

*) Make XMLResourceBundle (and -Factory) more extensible [CD]

*) XMLResourceBundles are not available outside a Request [CD]

*) Escape accolades in i18n messages [CD]

*) ContextSourceFactory calculates the path incorrectly when removing the protocol part [FC]

*) XMLEncoder doesn't support Unicode surrogate pairs [FC]

*) Content-Range and Range headers does not respect the HTTP spec [CD]

*) Inconsistent Content-Length header for HEAD requests [CD]

*) Cannot upload a file with name containing a '=' or a ';' [CD]

*) Unsynchronized HashMap.put in ResourceReader and GeneratorSelector may lead to infinite loop. [AN]

*) Update to poi-3.14 (requires Java 1.6) [AN]

*) Update to fop-1.1 [AN]

*) Update to commons-httpclient-3.1 [AN]

*) XSP: Use javax.tools.JavaCompiler interface for Javac (available since Java 6). [AN]

*) Core: Update to xalan-2.7.2 and add serializer-2.7.2 [AN]

*) Enable 'java' to be found by the build and run shell scripts on a modern Mac OS X. [DC]



---------------------------------------------------------------------
To unsubscribe, e-mail: users-unsubscr...@cocoon.apache.org
For additional commands, e-mail: users-h...@cocoon.apache.org

Reply via email to