Hello,

I am new here too. I am also playing with this example but my environment
is different from you which is ubuntu 16.04 and dpdk 16.07.2. My example
works fine with the parameters you given above.

Hugepages and drivers is correct. Do you see any EAL: message when starting
the program?

Best,
Mark

2017-01-13 16:12 GMT+08:00 David Aldrich <david.aldr...@emea.nec.com>:

> Hi
>
> To get familiar with DPDK, I am running the l2fwd example on a PC running
> Wind River Linux and fitted with an HP 560SFP+ 2-port NIC.  I enable one
> port for l2fwd and send UDP packets to it from another PC.  The problem is
> that the l2fwd example does not report these packets in its statistics - it
> reports 0 packets received.  I would like some advice on how to debug this
> please.
>
> Here's some more information:
>
> I have a bash script that initialises the dpdk environment and calls
> dpdk_nic_bind.py. The output looks ok and is shown at the end of this email.
>
> I run l2fwd as follows:
>
>        build/l2fwd -c f -n2 -- -q 1 -p 2
>
> This runs the example on 2 lcores, 1 port (the second one) and 1 rx queue
> per lcore.
>
> On the sending PC I have added an arp entry for the remote port and, using
> Wireshark, I can see that the UDP packet is sent with the correct MAC
> address.
>
> So all seems set up ok, but l2fwd does not see a packet.  Please can
> someone help me with this?
>
> Best regards
>
> David
>
> Output of bash script
> =================
>
> # ./leda_dpdk_setup.sh
> Using directory: /root/dpdk-2.2.0/x86_64-native-linuxapp-gcc
> HugePages_Total:      28
> HugePages_Free:        0
> HugePages_Rsvd:        0
> HugePages_Surp:        0
> Hugepagesize:    1048576 kB
> trying to remove old igb_uio module and may get an error message, ignore
> it trying to remove old rte_kni module and may get an error message, ignore
> it
>
> Network devices using DPDK-compatible driver ==============================
> ==============
> 0000:04:00.0 '82599ES 10-Gigabit SFI/SFP+ Network Connection' drv=igb_uio
> unused=windrvr1221
> 0000:04:00.1 '82599ES 10-Gigabit SFI/SFP+ Network Connection' drv=igb_uio
> unused=windrvr1221
>
> Network devices using kernel driver
> ===================================
> 0000:09:00.0 'I210 Gigabit Network Connection' if=eth0 drv=igb
> unused=windrvr1221,igb_uio
> 0000:0a:00.0 'I210 Gigabit Network Connection' if=eth1 drv=igb
> unused=windrvr1221,igb_uio *Active*
>
> Other network devices
> =====================
> <none>
>
> Command 'lspci | grep Ether' output for reference
> 04:00.0 Ethernet controller: Intel Corporation 82599ES 10-Gigabit SFI/SFP+
> Network Connection (rev 01)
> 04:00.1 Ethernet controller: Intel Corporation 82599ES 10-Gigabit SFI/SFP+
> Network Connection (rev 01)
> 09:00.0 Ethernet controller: Intel Corporation I210 Gigabit Network
> Connection (rev 03)
> 0a:00.0 Ethernet controller: Intel Corporation I210 Gigabit Network
> Connection (rev 03) root@localhost:~#
>

Reply via email to