Hi Mark

Thanks for your reply.  Below is the entire output.


Best regards


David


-----------------------------------------------


# build/l2fwd -c f -n2 -- -q 2 -p 3
EAL: Detected lcore 0 as core 0 on socket 0
EAL: Detected lcore 1 as core 1 on socket 0
EAL: Detected lcore 2 as core 2 on socket 0
EAL: Detected lcore 3 as core 3 on socket 0
EAL: Detected lcore 4 as core 4 on socket 0
EAL: Detected lcore 5 as core 5 on socket 0
EAL: Detected lcore 6 as core 0 on socket 1
EAL: Detected lcore 7 as core 1 on socket 1
EAL: Detected lcore 8 as core 2 on socket 1
EAL: Detected lcore 9 as core 3 on socket 1
EAL: Detected lcore 10 as core 4 on socket 1
EAL: Detected lcore 11 as core 5 on socket 1
EAL: Support maximum 128 logical core(s) by configuration.
EAL: Detected 12 lcore(s)
EAL: VFIO modules not all loaded, skip VFIO support...
EAL: Setting up physically contiguous memory...
EAL: Ask a virtual area of 0x340000000 bytes
EAL: Virtual area found at 0x7fee00000000 (size = 0x340000000)
EAL: Ask a virtual area of 0x3c0000000 bytes
EAL: Virtual area found at 0x7fea00000000 (size = 0x3c0000000)
EAL: Requesting 13 pages of size 1024MB from socket 0
EAL: Requesting 15 pages of size 1024MB from socket 1
EAL: TSC frequency is ~2394810 KHz
EAL: Master lcore 0 is ready (tid=cbe4b8c0;cpuset=[0])
EAL: lcore 3 is ready (tid=c9777700;cpuset=[3])
EAL: lcore 2 is ready (tid=c9f78700;cpuset=[2])
EAL: lcore 1 is ready (tid=ca779700;cpuset=[1])
EAL: PCI device 0000:04:00.0 on NUMA socket 0
EAL:   probe driver: 8086:10fb rte_ixgbe_pmd
EAL:   PCI memory mapped at 0x7ff140000000
EAL:   PCI memory mapped at 0x7ff140100000
PMD: eth_ixgbe_dev_init(): MAC: 2, PHY: 1
PMD: eth_ixgbe_dev_init(): port 0 vendorID=0x8086 deviceID=0x10fb
EAL: PCI device 0000:04:00.1 on NUMA socket 0
EAL:   probe driver: 8086:10fb rte_ixgbe_pmd
EAL:   PCI memory mapped at 0x7ff140104000
EAL:   PCI memory mapped at 0x7ff140204000
PMD: eth_ixgbe_dev_init(): MAC: 2, PHY: 12, SFP+: 3
PMD: eth_ixgbe_dev_init(): port 1 vendorID=0x8086 deviceID=0x10fb
EAL: PCI device 0000:09:00.0 on NUMA socket 0
EAL:   probe driver: 8086:1533 rte_igb_pmd
EAL:   Not managed by a supported kernel driver, skipped
EAL: PCI device 0000:0a:00.0 on NUMA socket 0
EAL:   probe driver: 8086:1533 rte_igb_pmd
EAL:   Not managed by a supported kernel driver, skipped
Lcore 0: RX port 0
Lcore 0: RX port 1
Initializing port 0... PMD: ixgbe_dev_rx_queue_setup(): sw_ring=0x7ff13e8fed40 
sw_sc_ring=0x7ff13e8fe800 hw_ring=0x7ff13e8ff280 dma_addr=0x43e8ff280
PMD: ixgbe_dev_tx_queue_setup(): sw_ring=0x7ff13e8ec640 hw_ring=0x7ff13e8ee680 
dma_addr=0x43e8ee680
PMD: ixgbe_set_tx_function(): Using simple tx code path
PMD: ixgbe_set_tx_function(): Vector tx enabled.
PMD: ixgbe_set_rx_function(): Vector rx enabled, please make sure RX burst size 
no less than 4 (port=0).
done:
Port 0, MAC address: 38:EA:A7:33:8F:68

Initializing port 1... PMD: ixgbe_dev_rx_queue_setup(): sw_ring=0x7ff13e8dbc40 
sw_sc_ring=0x7ff13e8db700 hw_ring=0x7ff13e8dc180 dma_addr=0x43e8dc180
PMD: ixgbe_dev_tx_queue_setup(): sw_ring=0x7ff13e8c9540 hw_ring=0x7ff13e8cb580 
dma_addr=0x43e8cb580
PMD: ixgbe_set_tx_function(): Using simple tx code path
PMD: ixgbe_set_tx_function(): Vector tx enabled.
PMD: ixgbe_set_rx_function(): Vector rx enabled, please make sure RX burst size 
no less than 4 (port=1).
done:
Port 1, MAC address: 38:EA:A7:33:8F:69


Checking link 
status..........................................................................................done
Port 0 Link Down
Port 1 Link Up - speed 10000 Mbps - full-duplex
L2FWD: lcore 1 has nothing to do
L2FWD: lcore 2 has nothing to do
L2FWD: entering main loop on lcore 0
L2FWD:  -- lcoreid=0 portid=0
L2FWD:  -- lcoreid=0 portid=1?

Reply via email to