If you have enabled them in $RTE_SDK/$RTE_TARGET/.config, they should be 
reflected in $RTE_SDK/$RTE_TARGET/include/rte_config.h. Do you see it defined 
there?
If not, perhaps you forgot to run make,
cd $RTE_SDK/$RTE_TARGET
vi .config <make stats config changes>
make
The lib/librte_pipeline, librte_port should recompile and you should see 
#define RTE_*_STATS_COLLECT 1 in $RTE_SDK/$RTE_TARGET/include/rte_config.h.
Once this is done, recompile your example application.
-- Original Message --
 
From: sharanya k [ksharanya...@gmail.com]
To: Heena Sirwani [heena.sirw...@nevisnetworks.com]
Cc: [users@dpdk.org]
Date: Fri 09 February 2018 [5:54:31 PM]
Subject: Re: [dpdk-users] Enabling stats in pipeline applications
Hi,
I made sure that all the stats are enabled in the .config file. I did
what you mentioned. Still, I stuck with the same problem(statistics
isn't coming). Can you please let me know if I have to do some other
steps to get my statistics in my ip pipeline application.
Thanks,
Sharanya
On Thu, Feb 8, 2018 at 7:41 PM, Heena Sirwani
<heena.sirw...@nevisnetworks.com> wrote:
>
>
>
> I had a similar issue. The problem turned out to be in configs.
> Make sure the configuration changes are made in the target in
> $RTE_SDK/$RTE_TARGET/.config.
> Either edit that config file for build local configs or remake target
> configuration by
>
> make config T=$RTE_TARGET
>
> -- Original Message --
>
> From: sharanya k [ksharanya...@gmail.com]
> To: [users@dpdk.org]
> Date: Thu 08 February 2018 [6:45:13 PM]
> Subject: [dpdk-users] Enabling stats in pipeline applications
>
>
> Hi,
> I am running an ip pipeline application in dpdk version 17.08.1
> (stable). I can see the packets getting received and send through
> Wireshark. But, I couldn't get the statistics in the pipeline app
> using the following command.
>
> pipeline> p 1 stats port in 0
> Pipeline 1 - stats for input port 0:
> Pkts in: 0
> Pkts dropped by AH: 0
> Pkts dropped by other: 0
> pipeline> p 2 stats port in 0
> Pipeline 2 - stats for input port 0:
> Pkts in: 0
> Pkts dropped by AH: 0
> Pkts dropped by other: 0
> pipeline> p 2 stats port out 0
> Pipeline 2 - stats for output port 0:
> Pkts in: 0
> Pkts dropped by AH: 0
> Pkts dropped by other: 0
>
> I even enabled the following flags in dpdk/config/common_base and
> recompiled.
> CONFIG_RTE_*_STATS_COLLECT=y
> Still its not working.
>
> Can you please help me to rectify this?
>
> Regards,
> Sharanya

Reply via email to