In case anyone else might need.

I solved this issue by installing the mlx4 related libraries from mlxn
ofed source for azure.

1) download source from:

http://www.mellanox.com/page/firmware_table_Microsoft?mtag=oem_firmware_download

Note: download the sources (48M), not the others. For some reason,
only the source package works for me.

2) unpack and install
./install.pl --guest --dpdk --upstream-libs

3) after installation completes, run
/etc/init.d/openibd restart

this will insert mlx4 related module into kernels.

After that, build dpdk and run testpmd seems working for me

So not sure what is the deal with the MLNX packages for Azure, but
this seems to be way for me to make it work.

Hope this may help someone else.




On Mon, Jan 8, 2018 at 11:42 PM, Stephen Hemminger
<step...@networkplumber.org> wrote:
> On Mon, 8 Jan 2018 11:01:09 +0800
> Hui Ling <kelvin.brookletl...@gmail.com> wrote:
>
>> Stephen,
>>
>> My last VM (DS3 v2, with 4 cores and 16GB memory) is in Canada East
>> and I got AN enabled on my subscription so AN worked just fine.
>>
>> For DPDK, I saw from your slides in DPDK submit last year saying
>> current DPDK solution in Azure needs:
>>
>> 1) Linux kerlnel 4.14
>
> You need transparent bonding support which is in kernel netvsc driver.
> It has been backported to Ubuntu Azure (4.13) package, RHEL 7 and SLES.
>
>
>
>> 2) 8 cores
>>
>> I am not sure if these are must. I tried to upgrade my Ubuntu to 4.14,
>> but then I ran into compilation issues with DPDK 17.11 for MLX4 PMD.
>> So I stayed with older version of kernel for Ubuntu 16.04.
>> With my config of VM, however, I could not get the failsafe.sh I got
>> from MS for azure to work.
>
> The number of cores requirement has been dropped, think it is available
> with 4 now.

Reply via email to