On installing gnuplot, I got a problem. pkg check -d reported this:

Checking all packages: 100%
apache24 is missing a required shared library: libaprutil-1.so.0
apache24 is missing a required shared library: libapr-1.so.0
apache24 is missing a required shared library: libdb-5.3.so.0
gcc-aux is missing a required shared library: libmpfr.so.4
gcc-aux is missing a required shared library: libmpc.so.3
gcc47 is missing a required shared library: libmpfr.so.4
gcc47 is missing a required shared library: libmpc.so.3
gnuplot is missing a required shared library: libgd.so.6
libva has a missing dependency: libGL
llvm36 is missing a required shared library: libedit.so.0
pulseaudio is missing a required shared library: libXtst.so.6
pulseaudio is missing a required shared library: libsndfile.so.1
pulseaudio is missing a required shared library: libltdl.so.7
xdriinfo has a missing dependency: libGL

>>> Missing package dependencies were detected.
>>> Found 1 issue(s) in the package database.

pkg: No packages available to install matching 'libGL' have been found in the 
repositories
>>> Summary of actions performed:

libGL dependency failed to be fixed

>>> There are still missing dependencies.
>>> Try fixing them manually.

>>> Also make sure to check 'pkg updating' for known issues.

pkg updating has a notice from four years ago about libGL which says to use 
portmaster. Is it still valid? Should I use portmaster?

When installing all the packages for gnuplot, it installed uk-libgd, but that 
conflicts with libgd. Which one should I have installed?

Pierre
-- 
Don't buy a French car in Holland. It may be a citroen.

Reply via email to