Hi all,

Does anyone here have any experience/worked with Java applications that use jna 
[2] or jffi [3] on DragonFly? I encountered a problem that maybe was solved 

I wanted to run most of my work related software on DragonFly. Among those 
things is Cassandra[1] itself and some services that connect to it. Everything 
runs mostly on the JVM but some of the Cassandra related libraries use native 
libs via jna and jffi. 

I got jna and jffi to build. But I get an exception when running the cassandra 
client (which uses jffi):

        mmap returned wrong address: wanted 0x400000, got 0x8f180000

which I comes from  /usr/src/libexec/rtld-elf/map_object.c (map_object()). This 
is pretty much outside of my domain but maybe some of you tried to do something 
similar? If anyone can explain why would mmap be unable to return the correct 
address (I’ve read the man page, but it's not obvious to me why it happens in 
my case) or can point me in some productive direction, I’d really appreciate it.


[1] Cassandra: http://cassandra.apache.org/ <http://cassandra.apache.org/>
[2] JNA: https://github.com/java-native-access/jna 
[3] JFFI: https://github.com/jnr/jffi <https://github.com/jnr/jffi>

Reply via email to