We should probably update the documentation to reflect where the machine 
specific info is, along the lines Ian points out.

I can give it a shot!

Mikael 

Sent from my iPhone

> On Aug 10, 2017, at 10:56 AM, users-requ...@einsteintoolkit.org wrote:
> 
> Send Users mailing list submissions to
>    users@einsteintoolkit.org
> 
> To subscribe or unsubscribe via the World Wide Web, visit
>    http://lists.einsteintoolkit.org/mailman/listinfo/users
> or, via email, send a message with subject or body 'help' to
>    users-requ...@einsteintoolkit.org
> 
> You can reach the person managing the list at
>    users-ow...@einsteintoolkit.org
> 
> When replying, please edit your Subject line so it is more specific
> than "Re: Contents of Users digest..."
> 
> 
> Today's Topics:
> 
>   1. Re: Changing the default directory for simulations
>      (Maitraya Bhattacharyya)
>   2. Re: Changing the default directory for simulations
>      (Maitraya Bhattacharyya)
>   3. Re: Changing the default directory for simulations
>      (Maitraya Bhattacharyya)
> 
> 
> ----------------------------------------------------------------------
> 
> Message: 1
> Date: Thu, 10 Aug 2017 22:02:05 +0530
> From: Maitraya Bhattacharyya <maitraya.li...@gmail.com>
> Subject: Re: [Users] Changing the default directory for simulations
> To: Ian Hinder <ian.hin...@aei.mpg.de>
> Cc: Einstein Toolkit Users <users@einsteintoolkit.org>
> Message-ID:
>    <caf9cbat_ygj-vzcu5_mjujq-ocz68vzuvqqjgtasazqalwc...@mail.gmail.com>
> Content-Type: text/plain; charset="utf-8"
> 
> Hi Ian,
> 
> Sorry! I forgot to reply to all.
> 
> My symfactory defs.local.ini is:
> 
> 
> [default]
> user            = mkb14ip002
> email           = mkb14ip002
> allocation      = NO_ALLOCATION
> 
> [CESSI-BEAST]
> user            = mkb14ip002
> email           = mkb14ip002
> allocation      = NO_ALLOCATION
> basedir     = /disk1/maitraya/Einstein_Toolkit/ET_Simulations
> 
> My machine is CESSI-BEAST, something that I added later for basedir to work.
> 
> The command I typed was:  ./simfactory/bin/sim submit static_tov
> --parfile=par/static_tov.par --procs=20 --walltime=8:0:0
> 
> And the output:
> Warning: simulation "static_tov" does not exist or is not readable
> Parameter file: /disk1/maitraya/Einstein_Toolkit/Cactus/par/static_tov.par
> Skeleton Created
> Job directory: "/disk1/maitraya/Einstein_Toolkit/ET_Simulations/static_tov"
> Executable: "/disk1/maitraya/Einstein_Toolkit/Cactus/exe/cactus_sim"
> Option list:
> "/disk1/maitraya/Einstein_Toolkit/ET_Simulations/static_tov/SIMFACTORY/cfg/OptionList"
> Submit script:
> "/disk1/maitraya/Einstein_Toolkit/ET_Simulations/static_tov/SIMFACTORY/run/SubmitScript"
> Run script:
> "/disk1/maitraya/Einstein_Toolkit/ET_Simulations/static_tov/SIMFACTORY/run/RunScript"
> Parameter file:
> "/disk1/maitraya/Einstein_Toolkit/ET_Simulations/static_tov/SIMFACTORY/par/static_tov.par"
> Assigned restart id: 0
> Error: Too many nodes specified: nodes=20 (maxnodes is 1)
> Aborting Simfactory.
> 
> Thanks,
> Maitraya.
> 
> 
>> On Thu, Aug 10, 2017 at 9:49 PM, Ian Hinder <ian.hin...@aei.mpg.de> wrote:
>> 
>> 
>> On 10 Aug 2017, at 11:08, Maitraya Bhattacharyya <maitraya.li...@gmail.com>
>> wrote:
>> 
>> Hi Ian,
>> 
>> I have got the basedir to work, but I cannot seem to change procs=1
>> 
>> Error: Too many nodes specified: nodes=20 (maxnodes is 1)
>> Aborting Simfactory.
>> 
>> When I used ubuntu.in, the ppn there was set to 256.
>> 
>> 
>> Hi,
>> 
>> (Please reply also to the list so that other can benefit.  I have re-added
>> users@einsteintoolkit.org to the CC.)
>> 
>> Can you post:
>> 
>> 1. The command that you typed and the error message
>> 2. The content of defs.local.ini
>> 3. The machine definition for the machine you are using
>> 
>> I assume you are trying now to use ubuntu.ini?
>> 
>> --
>> Ian Hinder
>> http://members.aei.mpg.de/ianhin
>> 
>> 
> -------------- next part --------------
> An HTML attachment was scrubbed...
> URL: 
> http://lists.einsteintoolkit.org/pipermail/users/attachments/20170810/f99d202a/attachment-0001.html
>  
> 
> ------------------------------
> 
> Message: 2
> Date: Thu, 10 Aug 2017 22:59:31 +0530
> From: Maitraya Bhattacharyya <maitraya.li...@gmail.com>
> Subject: Re: [Users] Changing the default directory for simulations
> To: Ian Hinder <ian.hin...@aei.mpg.de>
> Cc: Einstein Toolkit Users <users@einsteintoolkit.org>
> Message-ID:
>    <CAF9cbASELwBeNQo2=487dpvbwsu_zvbbqui+ltjykvzmae5...@mail.gmail.com>
> Content-Type: text/plain; charset="utf-8"
> 
> Hi Ian,
> 
> I noticed that there is a CESSI-BEAST.ini. I have 24 cores on my machine, I
> did the following changes,
> 
> ppn             = 256
> max-num-threads = 256
> num-threads     = 24
> nodes           = 1
> 
> While running, I see the following:
> 
> + set -e
> + cd
> /disk1/maitraya/Einstein_Toolkit/ET_Simulations/static_tov/output-0000-active
> + echo Checking:
> + pwd
> + hostname
> + date
> + echo Environment:
> + export CACTUS_NUM_PROCS=1
> + CACTUS_NUM_PROCS=1
> + export CACTUS_NUM_THREADS=24
> + CACTUS_NUM_THREADS=24
> + export GMON_OUT_PREFIX=gmon.out
> + GMON_OUT_PREFIX=gmon.out
> + export OMP_NUM_THREADS=24
> + OMP_NUM_THREADS=24
> + env
> + echo Starting:
> ++ date +%s
> + export CACTUS_STARTTIME=1502385989
> + CACTUS_STARTTIME=1502385989
> + mpirun -np 1
> /disk1/maitraya/Einstein_Toolkit/ET_Simulations/static_tov/SIMFACTORY/exe/cactus_sim
> -L 3
> /disk1/maitraya/Einstein_Toolkit/ET_Simulations/static_tov/output-0000/static_tov.par
> 
> I want to get the -np of the mpirun command to be 24. How do I achieve this
> ?
> 
> Maitraya.
> 
> On Thu, Aug 10, 2017 at 10:21 PM, Maitraya Bhattacharyya <
> maitraya.li...@gmail.com> wrote:
> 
>> Hi,
>> 
>> There isn't one, so I assume that I will have to create one ?
>> 
>> Maitraya.
>> 
>> On Thu, Aug 10, 2017 at 10:09 PM, Ian Hinder <ian.hin...@aei.mpg.de>
>> wrote:
>> 
>>> 
>>> On 10 Aug 2017, at 11:32, Maitraya Bhattacharyya <
>>> maitraya.li...@gmail.com> wrote:
>>> 
>>> Hi Ian,
>>> 
>>> Sorry! I forgot to reply to all.
>>> 
>>> My symfactory defs.local.ini is:
>>> 
>>> 
>>> [default]
>>> user            = mkb14ip002
>>> email           = mkb14ip002
>>> allocation      = NO_ALLOCATION
>>> 
>>> [CESSI-BEAST]
>>> user            = mkb14ip002
>>> email           = mkb14ip002
>>> allocation      = NO_ALLOCATION
>>> basedir     = /disk1/maitraya/Einstein_Toolkit/ET_Simulations
>>> 
>>> My machine is CESSI-BEAST, something that I added later for basedir to
>>> work.
>>> 
>>> The command I typed was:  ./simfactory/bin/sim submit static_tov
>>> --parfile=par/static_tov.par --procs=20 --walltime=8:0:0
>>> 
>>> And the output:
>>> Warning: simulation "static_tov" does not exist or is not readable
>>> Parameter file: /disk1/maitraya/Einstein_Toolk
>>> it/Cactus/par/static_tov.par
>>> Skeleton Created
>>> Job directory: "/disk1/maitraya/Einstein_Tool
>>> kit/ET_Simulations/static_tov"
>>> Executable: "/disk1/maitraya/Einstein_Toolkit/Cactus/exe/cactus_sim"
>>> Option list: "/disk1/maitraya/Einstein_Toolkit/ET_Simulations/static_tov/
>>> SIMFACTORY/cfg/OptionList"
>>> Submit script: "/disk1/maitraya/Einstein_Tool
>>> kit/ET_Simulations/static_tov/SIMFACTORY/run/SubmitScript"
>>> Run script: "/disk1/maitraya/Einstein_Toolkit/ET_Simulations/static_tov/
>>> SIMFACTORY/run/RunScript"
>>> Parameter file: "/disk1/maitraya/Einstein_Tool
>>> kit/ET_Simulations/static_tov/SIMFACTORY/par/static_tov.par"
>>> Assigned restart id: 0
>>> Error: Too many nodes specified: nodes=20 (maxnodes is 1)
>>> Aborting Simfactory.
>>> 
>>> 
>>> Please can you post simfactory/mdb/machines/CESSI-BEAST.ini?
>>> 
>>> You probably want to set "ppn = 20" in that file.
>>> 
>>> --
>>> Ian Hinder
>>> http://members.aei.mpg.de/ianhin
>>> 
>>> 
>> 
> -------------- next part --------------
> An HTML attachment was scrubbed...
> URL: 
> http://lists.einsteintoolkit.org/pipermail/users/attachments/20170810/bc5cfed3/attachment-0001.html
>  
> 
> ------------------------------
> 
> Message: 3
> Date: Thu, 10 Aug 2017 22:21:23 +0530
> From: Maitraya Bhattacharyya <maitraya.li...@gmail.com>
> Subject: Re: [Users] Changing the default directory for simulations
> To: Ian Hinder <ian.hin...@aei.mpg.de>
> Cc: Einstein Toolkit Users <users@einsteintoolkit.org>
> Message-ID:
>    <caf9cbaqdpfewuukyolbmnavs-sjvkny3vb7w9vhymswzo6f...@mail.gmail.com>
> Content-Type: text/plain; charset="utf-8"
> 
> Hi,
> 
> There isn't one, so I assume that I will have to create one ?
> 
> Maitraya.
> 
>> On Thu, Aug 10, 2017 at 10:09 PM, Ian Hinder <ian.hin...@aei.mpg.de> wrote:
>> 
>> 
>> On 10 Aug 2017, at 11:32, Maitraya Bhattacharyya <maitraya.li...@gmail.com>
>> wrote:
>> 
>> Hi Ian,
>> 
>> Sorry! I forgot to reply to all.
>> 
>> My symfactory defs.local.ini is:
>> 
>> 
>> [default]
>> user            = mkb14ip002
>> email           = mkb14ip002
>> allocation      = NO_ALLOCATION
>> 
>> [CESSI-BEAST]
>> user            = mkb14ip002
>> email           = mkb14ip002
>> allocation      = NO_ALLOCATION
>> basedir     = /disk1/maitraya/Einstein_Toolkit/ET_Simulations
>> 
>> My machine is CESSI-BEAST, something that I added later for basedir to
>> work.
>> 
>> The command I typed was:  ./simfactory/bin/sim submit static_tov
>> --parfile=par/static_tov.par --procs=20 --walltime=8:0:0
>> 
>> And the output:
>> Warning: simulation "static_tov" does not exist or is not readable
>> Parameter file: /disk1/maitraya/Einstein_Toolkit/Cactus/par/static_tov.par
>> Skeleton Created
>> Job directory: "/disk1/maitraya/Einstein_Toolkit/ET_Simulations/static_
>> tov"
>> Executable: "/disk1/maitraya/Einstein_Toolkit/Cactus/exe/cactus_sim"
>> Option list: "/disk1/maitraya/Einstein_Toolkit/ET_Simulations/static_
>> tov/SIMFACTORY/cfg/OptionList"
>> Submit script: "/disk1/maitraya/Einstein_Toolkit/ET_Simulations/static_
>> tov/SIMFACTORY/run/SubmitScript"
>> Run script: "/disk1/maitraya/Einstein_Toolkit/ET_Simulations/static_
>> tov/SIMFACTORY/run/RunScript"
>> Parameter file: "/disk1/maitraya/Einstein_Toolkit/ET_Simulations/static_
>> tov/SIMFACTORY/par/static_tov.par"
>> Assigned restart id: 0
>> Error: Too many nodes specified: nodes=20 (maxnodes is 1)
>> Aborting Simfactory.
>> 
>> 
>> Please can you post simfactory/mdb/machines/CESSI-BEAST.ini?
>> 
>> You probably want to set "ppn = 20" in that file.
>> 
>> --
>> Ian Hinder
>> http://members.aei.mpg.de/ianhin
>> 
>> 
> -------------- next part --------------
> An HTML attachment was scrubbed...
> URL: 
> http://lists.einsteintoolkit.org/pipermail/users/attachments/20170810/afb73ccd/attachment.html
>  
> 
> ------------------------------
> 
> _______________________________________________
> Users mailing list
> Users@einsteintoolkit.org
> http://lists.einsteintoolkit.org/mailman/listinfo/users
> 
> 
> End of Users Digest, Vol 89, Issue 4
> ************************************

_______________________________________________
Users mailing list
Users@einsteintoolkit.org
http://lists.einsteintoolkit.org/mailman/listinfo/users

Reply via email to