Thanks both for the informations.


I have tried to override the bndlib dependency to 4.0.0 this way:


But the error have persisted.

I will wait to try with 4.0.1 when it were release, since I've discovered that there are some issues with 4.0.0.

thanks all.

On 03/07/2018 17:38, Karl Pauls wrote:
On Tue, Jul 3, 2018 at 10:24 PM Raymond Auge <> wrote:
ComponentPropertyTypes only start to be recognized with bnd 4.0.0 and will
be fully with, as yet released, bnd 4.1.0.

Since the latest maven-bundle-plugin 3.5.0 only uses bnd 3.5.0 it's not
handled (note the versions are kept in sync for convenience).
Right, I guess we should try to at release a maven-bundle-plugin 4.0.0 soonish.

(I believe you can override the bnd version that is going to be used
by overriding the bndlib dependency of the maven-bundle-plugin but I
might be wrong)



- Ray

On Tue, Jul 3, 2018 at 3:28 PM, Cristiano <> wrote:


I'm trying to play with DS 1.4 @ComponentPropertyType.

I've created an annotation:

public @interface Config {

      * @return
     String participant_id();

then I tried to use it in activate method:

     @Config(participant_id = "category")
     protected void activate(ComponentContext pInjectedComponentContext,
             Map<String, Object> pProperties,
             DsConfigParticipant pConfigProperties)

but M-B-P gives me an manifest generation exception:

[ERROR] Manifest
ch.osgi.core:jar:0.1.1-SNAPSHOT : Activate method for
descriptor ()Ljava/lang/String; is not acceptable.



To unsubscribe, e-mail:
For additional commands, e-mail:

*Raymond Augé* <>
Senior Software Architect *Liferay, Inc.* <>
Board Member & EEG Co-Chair, OSGi Alliance <> (@OSGiAlliance)

To unsubscribe, e-mail:
For additional commands, e-mail:

Reply via email to