Pas de moi cette procédure, mais je peux tester ce soir.... Si le midleware
eid est déjà installé sur ton Ubuntu, à mon avis tu n'as qu'à faire les
étapes 2) et 4).


I regroup here informations received from various sources.

   - 1) Install the belgian eid middleware

I don't remember how i did that, but it worked flawesly and immediately...
Please help me on this :-)

   - 2) Install Adobe Reader (thanks to https://askubuntu.com/a/805399):

sudo add-apt-repository "deb http://archive.canonical.com/ precise partner"
sudo apt-get update sudo apt install adobereader-enu

!! when you launch it for the first time, it takes a loooonnnngggg time to
show up (far more than a minute).

   - Make Adobe use the eid:

Install i386 flavor of pkcs library:

3) apt-get install libbeidpkcs11.so:i386

4) Locate libbeidpkcs11.so (in my install, it is in
/usr/lib/i386-linux-gnu/libbeidpkcs11.so.0):

dpkg -L libbeidpkcs11-0:i386

Launch Adobe Reader and go to Documents -> Security Settings -> PKCS# 11
Module. Then Click on "Attach Module" and browse to libbeidpkcs11.so

And voilà (more or less)


nb: la manière d'importer le pdf en Libreoffice modifie le pdf initial,
donc pas sûr que ce soit "légal" et en tous les cas, ne marcherait pas pour
les formulaires.


Yves


Le 12 avril 2018 à 12:42, <demande_aide...@libreoffice.org> a écrit :

> Bonjour
>
> Voici une nouvelle question envoyée à l'aide du formulaire de demande
> d'aide (http://fr.libreoffice.org/get-help/poser-une-question/).
> Si vous répondez, merci de penser à utiliser la fonction "répondre à tous"
> de votre logiciel de courrier électronique de façon que le demandeur
> reçoive une copie de votre réponse.
>
>
> Email:: fourrey...@laposte.net
> Sujet:: ouverture PDF à signer
> OS:: Linux
> Version:: 6.0.x
> Question:: Bonjour,
> Ayant lu que l'on pouvait signer un PDF dans LO
> Je souhaitai importer l'accusé de réception à signer de ma déclaration TVA
> (docu pdf du SPF finance belge) sous Linux Ubuntu, dans les versions 5.1 à
> 6.0 de LO l'affichage ne se fait pas et le message suivant est mentionné ;
> To view the full contents of this document, you need a later version of
> the PDF viewer. You can upgrade
> to the latest version of Adobe Reader from www.adobe.com/products/
> acrobat/readstep2.html
> Si je signe le PDF sous Windows dans acrobat et que je l'importe de
> nouveau dans LO sous Linux Ubuntu l'affichage de fait normalement .
> Quelqu'un a-t-il une solution ?
> Merci
>
>
>
> --
> Envoyez un mail à users+unsubscr...@fr.libreoffice.org pour vous
> désinscrire
> Les archives de la liste sont disponibles à https://listarchives.
> libreoffice.org/fr/users/
> Tous les messages envoyés sur cette liste seront archivés publiquement et
> ne pourront pas être supprimés
>



-- 
web site : http://www.molenbaix.com

-- 
Envoyez un mail à users+unsubscr...@fr.libreoffice.org pour vous désinscrire
Les archives de la liste sont disponibles à 
https://listarchives.libreoffice.org/fr/users/
Tous les messages envoyés sur cette liste seront archivés publiquement et ne 
pourront pas être supprimés

Répondre à