Hello,
We are porting our framework to Grails 8.0.0(-M3), which defaults to Groovy 5.0.7. This framework generates getters from an AST Transformation at compile time. Symbols generated are then used into some DSLs to compose elements of our apps. There is an exception when launching our test app if the name of the getters ends with an '_'; like in "getFirstName*_*()", if I replace the '_' with another char, it fails after (missing symbols, because I use 'someone.firstName_' in the code). Is there any restriction regarding the naming conventions for getters in Groovy 5 ? If not, I will dig further and fill an eventual bug report if needed. Regards -- Adrien Guichard + 33 6 10 78 75 88 Taack / Citel / Obsta 29 Boulevard Edgar Quinet 75014 Paris
