Could you try any of the HTTP urls , i am not sure why it is n't working
for me i can see that you are proxying to 192.IP ,but on mine i still get
connection abort when it try with below configuration

and when tried cul with option --proxy-insecure that option dosen't seems
to be available

# cat  virtualhosts.conf

Listen 443 https

<VirtualHost _default_:443>

LoadModule proxy_connect_module modules/mod_proxy_connect.so
LogLevel debug

SSLProtocol all -SSLv2

SSLCertificateFile /etc/pki/tls/certs/1.cert

SSLCertificateKeyFile /etc/pki/tls/private/1.key

SSLCACertificateFile /etc/pki/tls/certs/intermediate.crt
  ProxyRequests On
ProxyVia On
SSLProxyEngine On
<Proxy "*">
     Require expr %{HTTP_HOST} =~ /^example.com:443$/
     Require expr %{HTTP_HOST} =~ /^$/



  *curl -k --proxy <> <> -v -v*
* About to connect() to proxy port 443 (#0)
*   Trying
* Connected to ( port 443 (#0)
* Establish HTTP proxy tunnel to
> Host:
> User-Agent: curl/7.29.0
> Proxy-Connection: Keep-Alive
* Proxy CONNECT aborted
* Connection #0 to host left intact
*curl: (56) Proxy CONNECT aborted*

curl --proxy-insecure --proxy https://www.google.com
-v -v
*curl: option --proxy-insecure: is unknown*
curl: try 'curl --help' or 'curl --manual' for more information

Reply via email to