姉崎です。

野方さん

 お世話になります。

On 2020/05/29 13:23, Jun Nogata wrote:
> OSCのSlackを見て気になったので、ちょっと深く検証してみました。

お手間取らせて、すいません。

> ズームのアニメーションを使うと問題が出るようです。調べた結果はこんな感じでした。
> 
> - オブジェクトを2つ並べて、両方にズームのアニメーションを適用すると同じ現象がおきます。
> - 1つだけの場合は、オブジェクトは表示されるけれどズームのアニメーションは実行されません。
> - ズームのアニメーションを別のアニメーションに置き換えると大丈夫でした。
> - テキストにつけたズームのアニメーションは問題ありません。
> - オプションからハードウェアアクセラレーションを無効にするとオブジェクトも動きました。
> 
> Bigzillaを検索するとこういうバグが見つかりました。これと同じですね。
> 
> * 103423 – Linux: drawing object with Zoom animation not displayed in
> Impress slideshow:
> https://bugs.documentfoundation.org/show_bug.cgi?id=103423

6.2.8.2で登録されていますが、私の場合、6.2.8.2まで大丈夫だったし、
GPUごとで出たり出なかったりするみたいですね。
私のはIntel HD Graphics 520みたいです。

> 6.4.4も7.0デイリービルドでも同じ症状だったので、全然直っていないことを追記したほうがいいかもですね。
> 
> とりあえず回避策としては
> アニメーションにこだわりがなければ、ズームの部分を別のアニメーションに置き換えるのはいかがでしょうか。
> ズームを使いたいなら、オプションのハードウェアアクセラレーションを無効にするのはいかがでしょうか。

サジェッションありがとうございます。

アニメーションは、会社のブランドステートメントを複数の画像をワイプで表示させるときに、
ハードウェアアクセラレーションを有効にしないとキレイに出ないんです。
 https://www.youtube.com/watch?v=YzlxUUyXqMI&t=34s
の20-27秒のところのタクトの動きが、無効にすると白いギザギザになるんです。

ズームの動きにこだわりは無いのですが、有償講義の150枚を超えるスライドで使っているところを
漏らさず探すのが大変で諦めました。
2017/08/01 11:09の時に教えてもらったcontent.xmlの中身を検索するしか無いのでしょうか?

アニメーションの効果を検索したり、デフォルト(私はほとんどワイプの左から、直前の動作の後が多い)を
指定できたり(統計情報で最頻ベスト3とかでもいいし)するといいのにね、と思う。
無い物ねだりですが。

-- 


-- 
Unsubscribe instructions: E-mail to users+unsubscr...@ja.libreoffice.org
Posting guidelines + more: https://wiki.documentfoundation.org/Netiquette
List archive: https://listarchives.libreoffice.org/ja/users/
Privacy Policy: https://www.documentfoundation.org/privacy

メールによる返信