I beg your pardon for my previous message: wrong mailing list, sorry!

On Wed, 12 Oct 2016 16:09:45 +0200, Sergiy Shyrkov <my.public.mail...@gmail.com> wrote:

Hello guys,

I would need your help with karaf-maven-plugin, please.
I cannot find out the minimal version of Maven which is required to use karaf-maven-plugin:features-generate-descriptor goal (in version 4.0.7).

In the Karaf docs, the only mention of Maven version is in the "4.1.4. Building from Sources" section (http://karaf.apache.org/manual/latest/#_building_from_sources), which states:

     Apache Maven 3.0.4 or greater

We've migrated to Karaf 4.0.7 and that version of the karaf-maven-plugin and our build with Maven 3.0.5 (on our CI server, as locally no one is using Maven 3.0 :-)) fails with a ClassCastException (I am appending the stacktrace at the end of this message).

Seems the changes for https://issues.apache.org/jira/browse/KARAF-884 ( https://github.com/apache/karaf/commit/2d96f914382423762f86c3432587510247beb955 ) have broken the compatibility with Maven 3.0.x as it introduced into GenerateDescriptorMojo.java the usage of the org.eclipse.aether.artifact.DefaultArtifact class which is not compatible with Maven 3.0.

Would you let me know, if this was on purpose and now the minimal Maven version required to use the plugin is 3.1.x or this is a kind of side-effect/regression?

Thank you in advance!

Kind regards

Sergiy Shyrkov
Software Architect
Jahia Solutions Group SA

Reply via email to