Hi,I am using Jackrabbit oak standalone application ( version 1.8.2 ) as
spring boot enabled.

After building using "mvn clean install" and I ran the jar in the command
line "java -jar target\jackrabbit-oak-server-0.0.1-SNAPSHOT.jar". But the
repository is not getting up.

I debugged the application and found that the
"org.apache.jackrabbit.oak.run.osgi.SpringBootSupport" class accessing the
getUrl() method from the org.springframework.boot.loader.jar.JarEntry class
via reflection. Here is the method. And highlighted the code accessing the
getUrl method.

private static Method getUrlMethod(JarEntry jarEntry) throws
NoSuchMethodException {            if (ENTRY_URL_METHOD == null){               
"JarEntry class %s does not belong to Spring package", jarEntry.getClass());    
*ENTRY_URL_METHOD = jarEntry.getClass().getMethod("getUrl");*            }      
return ENTRY_URL_METHOD;        }

And getUrl() method is not a public method in the
org.springframework.boot.loader.jar.JarEntry class. 

And here i attached the log file.


This is the error from log file.

*18:51:19.104 [main] WARN  o.a.j.oak.run.osgi.SpringBootSupport - Error
occurred while fetching jar entry
OSGI-INF/org.apache.jackrabbit.oak.jcr.osgi.RepositoryManager.xml from
org.springframework.boot.loader.jar.JarEntry.getUrl()        at
java.lang.Class.getMethod(Unknown Source) ~[na:1.8.0_141]*

If I ran this application from eclipse by right click the main class,
application is working fine.

Please assist me to fix this issue. 


Sent from: http://jackrabbit.510166.n4.nabble.com/Jackrabbit-Users-f510167.html

Reply via email to