After this morning's updates, I noticed that a bunch of common keyboard shortcuts didn't work. In gnome-terminal, shift-insert didn't paste selected text. In thunderbird, 'b' wouldn't move to the previous message in the folder, but only if the keyboard focus was in the message body pane. In firefox, the up and down arrow keys moved between links rather than scrolling the page up and down.

I tried dnf history rollback, but a number of the previous package versions aren't available, to that failed. Grump: there's no point in having "history rollback" if packages don't remain available in the updates tree long enough to roll back to when there are problems.


Then I tried gathering the names of updated packages and using "dnf downgrade" instead. That caused dnf to offer to install dozens of i686 packages that are not currently installed. I tracked that to evolution-data-server. Why downgrading that tries to install i686 packages is unfathomable.

Excluding that, the downgrade didn't resolve the problem, but at that point I noticed that the "orca" process was using a whole lot of CPU time. I killed it, and at that point keyboard shortcuts were restored.

My guess is that this is related to the python3 package upgrades somehow, but downgrading them didn't fix the problem. I'm going to try to find time later to resume troubleshooting this, unless someone beats me to it.

In the mean time: if you're having problems with keyboard input after updating, killing the "orca" process will work around the problem until the root cause has been found and fixed.
_______________________________________________
users mailing list -- users@lists.fedoraproject.org
To unsubscribe send an email to users-le...@lists.fedoraproject.org

Reply via email to