On Saturday 08 October 2016 11:02:48 Ahmad Samir wrote:
> On 7 October 2016 at 16:05, Gary Stainburn
> <gary.stainb...@ringways.co.uk> wrote:
> > I don't know when it stopped working working, but it was recently.
> > Unfortunately, with almost daily updates I don't know what's caused it.
> >
> > I have menu entried within my KDE which start a ssh command inside a
> > konsole. This has worked fine for as long as I can remember (F9 or
> > before)
> >
> > However, now when I try, I get the launch feedback, the konsole window
> > never opens.
> >
> > If I open a konsole session, e.g. by right clicking the desktop, and then
> > run the ssh command then all works fine.
> >
> > Can annyone suggest how I can debug/fix the problem?
> That looks similar to this upstream bug:
> https://bugs.kde.org/show_bug.cgi?id=366793

I have tried replicating this bug on my system, but don't have a problem.

The bug reports that the '-c' argument is not recognised. However, when I try 
it, the command works, with a new konsole window opening and the ssh command 
working.  I do get an error when I close the new child window, but that is 

However, while testing this I found an odd behaviour.  If I run the command

konsole -e bash -c "root ollie"

it works and I have a konsole session which is logged into Ollie.  However, if 
I do

konsole -e sh -c "ssh -Y C -l root ollie"

it briefly opens the window but then immediately closes it, presumably because 
the SSH has failed.  The odd thing is that the two commands are effectively 
the same thing

[gary@gary ~]$ cat bin/root

if [ "$1" == "" ]; then

ssh  -Y -C -l root $host $*
[gary@gary ~]$ 
users mailing list -- users@lists.fedoraproject.org
To unsubscribe send an email to users-le...@lists.fedoraproject.org

Reply via email to