On 03/05/2018 08:20 PM, Ed Greshko wrote:
On 03/06/18 07:12, Temlakos wrote:
On 03/05/2018 02:56 PM, Ed Greshko wrote:
On 03/05/18 23:24, Temlakos wrote:
[Temlakos@temlakos Other]$ youtube-dl https://youtu.be/mqbcEw7AkU8
[youtube] mqbcEw7AkU8: Downloading webpage
ERROR: Unable to download webpage: <urlopen error [Errno -2] Name or service not
known> (caused by URLError(gaierror(-2, 'Name or service not known'),))
This is telling you that DNS resolution isn't working.

What do you get for....

host youtu.be

[Temlakos@temlakos ~]$ host youtu.be
youtu.be has address
youtu.be has IPv6 address 2607:f8b0:4006:81b::200e
youtu.be mail is handled by 10 aspmx.l.google.com.
youtu.be mail is handled by 10 gmr-smtp-in.l.google.com.
youtu.be mail is handled by 30 alt2.aspmx.l.google.com.
youtu.be mail is handled by 50 alt4.aspmx.l.google.com.
youtu.be mail is handled by 40 alt3.aspmx.l.google.com.
youtu.be mail is handled by 20 alt1.aspmx.l.google.com.
[Temlakos@temlakos ~]$

Well, that is what you should get.

I can only reproduce the error you're seeing by modifying /etc/resolv.conf to 
break DNS.

So, why it isn't working on your system is a mystery.  youtube-dl is written in
python.  If you know how to debug it, you should.   Or, if you've made manually
changes to your system in the area of python you may want to check your work.

It would appear that my system can resolve domains like "youtube.com" but not the short form "youtu.be".

Because I just tried a download using the long-form URL--the standard URL to which you always navigate, not the short-form URL you get from the "share" routine. The download worked, exactly as your example did, even to producing a good Matroska video file.

users mailing list -- users@lists.fedoraproject.org
To unsubscribe send an email to users-le...@lists.fedoraproject.org

Reply via email to