On 03/13/2018 02:39 AM, Lukas Vrabec wrote:
On 03/13/2018 06:57 AM, ToddAndMargo wrote:
Follow up:

With everyone's help, I cleaned up my SELinux homedir's
and set Samba's SELinux stuff right.

I still could not log in from lightdm, except to root,
when SLElinux was Enforcing.

And SEAlert was completely quiet.  And
      /var/log/audit/audit.log
was completely empty.

Then I got sneaky and created a new user in a different
root directory (/home2).  That worked.  Hmmmmmmm.....

So I renamed my $HOME director and recreated and empty
one.  That worked too.  POOP !!!!!!

So I though of trying to trace down who was doing it.  Gave
up and restored my user's directories from backup. That also
worked!

Yippee!

Thank you all for the tips.  I wrote down about five of them,
so I would not forget.  SELinux baffles me at times.


I'm quite lost with your e-mails, but how it's labeled right now in your
homedir? It shouldn't be samba_share_t if it's working and also, could
you please attach output of:

# semanage export

Thanks,
Lukas.

What is the command telling me?


# semanage export
boolean -D
login -D
interface -D
user -D
port -D
node -D
fcontext -D
module -D
boolean -m -1 daemons_use_tty
boolean -m -1 named_write_master_zones
boolean -m -1 samba_domain_controller
boolean -m -1 samba_enable_home_dirs
boolean -m -1 samba_export_all_rw
fcontext -a -f a -t samba_share_t '/home(/.*)?'
fcontext -a -f a -t samba_share_t '/home/CDs(/.*)?'
fcontext -a -f a -t samba_share_t '/home/OurStuff(/.*)?'
fcontext -a -f a -t chrome_sandbox_exec_t '/usr/lib/chrome-sandbox'
fcontext -a -f a -t bin_t '/usr/lib/chromium-browser'
fcontext -a -f a -t bin_t '/usr/lib/chromium-browser/chromium-browser.sh'
fcontext -a -f a -t rpm_exec_t '/usr/share/dnfdaemon/dnfdaemon-system'
fcontext -a -e /home /home/users
fcontext -a -e /home /nfshome
_______________________________________________
users mailing list -- users@lists.fedoraproject.org
To unsubscribe send an email to users-le...@lists.fedoraproject.org

Reply via email to