Le 11/04/2018 à 13:48, Kevin Klein a écrit :
> On Mon, 9 Apr 2018 at 17:38:50, Colomban Wendling wrote:
> 
>> Why are you setting GLIB_CFLAGS?  You shouldn't do that manually but on
>> *very* specific cases.  Normally it should discover the appropriate
>> flags through the pkg-config system, and those should be correct.
> 
> I set that flag because I was receiving the exact same error before I
> set it.  I tried a new build with only the following sequence of commands:
> 
> setenv PATH /user/kklein/lib/intltool/0.50.2/bin:$PATH
> setenv PKG_CONFIG_PATH /user/kklein/geany/1.33/lib/pkgconfig
> setenv GEANY_CFLAGS -I/user/kklein/geany/1.33/include/geany

Again, it's odd that you'd have to set this.  What does

$ PKG_CONFIG_PATH=/user/kklein/geany/1.33/lib/pkgconfig pkg-config
--modversion geany
give you?

Similarly, what does

$ pkg-config --modversion glib-2.0

give you?
_______________________________________________
Users mailing list
Users@lists.geany.org
https://lists.geany.org/cgi-bin/mailman/listinfo/users

Reply via email to