Dear Peter,
     I got info from the net that OPenmpi requires F77 bindings for F90
support. Thats where I was making mistake, i didnt configured for F77
bindings during openmpi setup. I rectified my mistake and after that
was installed successfully for both PGI and INTEL compiler.

It was great help from you.  :-)

Thanks and Regards,

>Dear Peter,
>    Your suggestions did worked, it didnt showed any error during make and
>make install. But it didnt got installed with mpif90 support. I tried to
>compile my mpi code, but it gave following error.

>[vighnesh@test_node SIVA]$ /share/apps/mpi/openmpi/intel/bin/mpif90
code.f >-o code.exe
>Unfortunately, this installation of Open MPI was not compiled with
Fortran >90 support.  As such, the mpif90 compiler is non-functional.

> My configure script line is:
>[root@test_node vighnesh]# ./configure
>--prefix=/share/apps/mpi/openmpi/intel FC=ifort --with-tm=/opt/torque

>Please help me.

>Thanks and Regards,

> On Wednesday 30 September 2009, wrote:
> ...
>> during
>> configuring with Intel 9.0 compiler the installation gives following
>> [root@test_node openmpi-1.3.3]# make all install
> ...
>> make[3]: Entering directory `/tmp/openmpi-1.3.3/orte'
>> test -z "/share/apps/mpi/openmpi/intel/lib" || /bin/mkdir -p
>> "/share/apps/mpi/openmpi/intel/lib"
>>  /bin/sh ../libtool   --mode=install /usr/bin/install -c
>> ''
>> '/share/apps/mpi/openmpi/intel/lib/'
>> libtool: install: error: cannot install `' to a directory
not ending in /share/apps/mpi/openmpi/pgi/lib
> The line above indicates that you've somehow attempted this from a dirty
> and/or environment (dirty from the previous pgi installation...).
> Try a clean environment, clean build tree. Source the icc/
> from your intel install dir, set CC, CXX, FC, F77 and do:
>  "./configure --prefix=... && make && make install"
> /Peter

Reply via email to