Maybe just --with-valgrind or --with-valgrind=/usr would work?

On 07/14/2016 11:32 AM, David A. Schneider wrote:
I thought it would be a good idea to build a debugging version of
openmpi 1.10.3. Following the instructions in the FAQ:
https://www.open-mpi.org/faq/?category=debugging#memchecker_how
<https://email.slac.stanford.edu/owa/redir.aspx?REF=RP5_rOiQ9WZQgiVLWWUfJLansCsxNMkiYakBQ0zCua7x_z9A-6vTCAFodHRwczovL3d3dy5vcGVuLW1waS5vcmcvZmFxLz9jYXRlZ29yeT1kZWJ1Z2dpbmcjbWVtY2hlY2tlcl9ob3c.>
I went with

.configure —with-verbs —enable-debug —enable-memchecker
—with-valgrind=/usr/bin/valgrind

Since I discovered valgrind was already installed on our network (this
is rhel7). However configure fails, and part of the error messages read

WARNING Expected file /usr/bin/include/valgrind/valgrind.h not found

Is there a way to build openmpi to use the installation of valgrind on
my system? I’m not sure if/where the valgrind.h file is, I don’t see it
in /usr/include. If not, I will build against my own build of valgrind,
but I run into similiar error messages - the auto tools script is not
finding the headers my valgrind install - I've tried giving a full path
to valgrind, the directory I used for PREFIX when I installed valgrind,
there must be some assumptions about environment variables I need to
have set to get the openmpi install script to work?

Reading through a page on valgrind:
http://valgrind.org/docs/manual/mc-manual.html#mc-manual.mpiwrap
<https://email.slac.stanford.edu/owa/redir.aspx?REF=RUoQIaKZhwLZN3KFa0DpMOj3B1mLOQzP7xrqLqeC7obx_z9A-6vTCAFodHRwOi8vdmFsZ3JpbmQub3JnL2RvY3MvbWFudWFsL21jLW1hbnVhbC5odG1sI21jLW1hbnVhbC5tcGl3cmFw>


I found instructions to the effect of how to wrap valgrind around an
existing open-mpi install. Does any one know which is better? That is,
what I'm trying, to build open-mpi based on a valgrind install, or to
install valgrind based on a open-mpi install? Doing both looks like a
circular dependency.

Best,

David
_______________________________________________
users mailing list
us...@open-mpi.org
Subscription: https://www.open-mpi.org/mailman/listinfo.cgi/users
Link to this post:
http://www.open-mpi.org/community/lists/users/2016/07/29668.php


Reply via email to