I've installed openmpi-v4.0.0rc5 on my "SUSE Linux
Enterprise Server 12.3 (x86_64)" with Sun C 5.15 (Oracle Developer
Studio 12.6), gcc-6.4.0, icc-19.x, and pgcc-18.4 Unfortunately, I
still get the same error that I reported yesterday.

loki config_files 114 mpicc --showme
gcc -I/usr/local/openmpi-4.0.0_64_gcc/include -fexceptions -pthread -std=c11 -m64 -Wl,-rpath -Wl,/usr/local/openmpi-4.0.0_64_gcc/lib64 -Wl,--enable-new-dtags -L/usr/local/openmpi-4.0.0_64_gcc/lib64 -lmpi

loki config_files 115 which mpiexec

loki config_files 116 tail -1 rf_loki
rank 0=loki slot=0:0;1:0

loki config_files 117 mpiexec -report-bindings -np 1 -rf rf_loki hostname
[loki:01325] [[39569,0],0] ORTE_ERROR_LOG: Data unpack would read past end of buffer in file ../../../../openmpi-4.0.0rc5/orte/mca/odls/base/odls_base_default_fns.c at line 612
loki config_files 118

I would be grateful, if somebody can fix the problem. Do you need anything
else? Thank you very much for any help in advance.

Kind regards

users mailing list

Reply via email to