you need to export PATH and LD_LIBRARY_PATH in your .bashrc

(e.g. export PATH=$HOME/openmpi/bin:$PATH)

Also, make sure you built your application with Open MPI installed in $



----- Original Message -----

Hi folks,

After installing OpenMPI, I executed these lines

echo 'PATH=$HOME/openmpi/bin:$PATH' >> ~/.bashrc
echo 'LD_LIBRARY_PATH=$HOME/openmpi/' >> ~/.bashrc
source. bashrc

and run  a simple file by using

mpirun np 1 helloworld

The error message is

helloworld: error while loading shared libraries: 
cannot open shared object file: No such file or directory
mpirun noticed that the job aborted, but has no info as to the process
that caused that situation.
 It is about inaccurate linking the libraries but I could not fix it. 
When i run ldd helloworld, this appears (0x00007fff8f2d2000) => not found => not found => /lib64/ (0x00007fbc21e55000) => /usr/lib64/ (0x00007fbc21acb000) => /lib64/ (0x00007fbc218b3000) => /lib64/ (0x00007fbc21696000) => /lib64/ (0x00007fbc212f1000)
    /lib64/ (0x00007fbc22152000)
Do you have any idea to fix it ?


Serdar Hiçdurmaz <>, 23 Oca 2019 Çar, 16:26 
tarihinde şunu yazdı:
Thanks Ralph. It worked. 


Ralph H Castain <>, 23 Oca 2019 Çar, 15:48 tarihinde ş
unu yazdı:
Your PATH and LD_LIBRARY_PATH setting is incorrect. You installed OMPI 
into $HOME/openmpi, so you should have done:



On Jan 23, 2019, at 6:36 AM, Serdar Hiçdurmaz <
> wrote:

Hi All,

I try to install Open MPI, which is prerequiste for liggghts (DEM 
software). Some info about my current linux version :

PRETTY_NAME="SUSE Linux Enterprise Desktop 12 SP3"

I installed Open MPI 1.6 by typing

./configure --prefix=$HOME/openmpi
make all
make install

Here, it is discussed that openmpi 1.6 is compatible with OpenSuse 12.3

To add OpenMPI to my path and LD_LIBRARY_PATH, I execute the following 
comands on terminal:

export PATH=$PATH:/usr/lib64/mpi/gcc/openmpi/bin
export LD_LIBRARY_PATH=$LD_LIBRARY_PATH:/usr/lib64/mpi/gcc/openmpi/lib64

Then, in /liggghts/src directory, I execute make auto, this appears :

Creating list of contact models completed.
make[1]: Entering directory '/home/serdarhd/liggghts/LIGGGHTS-PUBLIC/src
Makefile:456: *** 'Could not compile a simple MPI example. Test was done 
with MPI_INC="" and MPICXX="mpicxx"'. Stop.
make[1]: Leaving directory '/home/serdarhd/liggghts/LIGGGHTS-PUBLIC/src/
Makefile:106: recipe for target 'auto' failed
make: *** [auto] Error 2

Do you have any idea what the problem is here ? I went through the "
makefile" but it looks like quite complicated as linux beginner like me.

Thanks in advance. Regards,


users mailing list

users mailing list
users mailing list

Reply via email to