I have a parallelized code that works fine on my local computer with the 

   $mpirun -n 5 python parallel_simulation.py
but when I try the same code on cluster I only get one process and it is not 
running in parallel. I have both mpich and openmpi loaded on my cluster. 

I tried to use 

$mpirun -n 5 -hostfile /etc/hosts python parallel_simulation.py
which gives me error 

Open RTE detected a parse error in the hostfile:


It occured on line number 39 on token 12.
An internal error has occurred in ORTE:

[[57450,0],0] FORCE-TERMINATE AT (null):1 - error base/ras_base_allocate.c(302)

This is something that should be reported to the developers.
This is what I get when I run:

$cat /etc/hosts

# Ansible managed file, do not edit directly   localhost localhost.localdomain localhost4 localhost4.

::1         localhost localhost.localdomain localhost6 localhost6.

# Hosts from ansible hosts file titan-install.int.utu.fi titan-install titan-admin.int.utu.fi titan-admin titan-grid.int.utu.fi titan-grid ti1.int.utu.fi ti1 ti1-ib.int.utu.fi ti1-ib ti2.int.utu.fi ti2

I would be very grateful if someone could suggest a solution. I am very new to 
this and I am not sure how to solve the problem.
users mailing list

Reply via email to