Is /var/lib/etcd your etcd data directory?  Ie is there anything in that
folder?

On Feb 13, 2018, at 4:50 PM, Feld, Michael (IMS) <fe...@imsweb.com> wrote:

Hi all,



I am trying to use the ansible playbook to migrate etcd from v2 to v3 for a
3.6.0 origin cluster and it keeps failing with the following:



fatal: [openshift-master]: FAILED! => {"changed": false, "failed": true,
"msg": "Before the migration can proceed the etcd member must write down at
least one snapshot under /var/lib/etcd//member/snap directory."}



I have tried using the release-3.6 branch of openshift-ansible as well as
the master branch migrate.yml playbooks, both give the same result. It
doesn’t even look from the ansible output that it’s even taking a snapshot.
What am I doing wrong?



Mike

------------------------------

Information in this e-mail may be confidential. It is intended only for the
addressee(s) identified above. If you are not the addressee(s), or an
employee or agent of the addressee(s), please note that any dissemination,
distribution, or copying of this communication is strictly prohibited. If
you have received this e-mail in error, please notify the sender of the
error.

_______________________________________________
users mailing list
users@lists.openshift.redhat.com
http://lists.openshift.redhat.com/openshiftmm/listinfo/users
_______________________________________________
users mailing list
users@lists.openshift.redhat.com
http://lists.openshift.redhat.com/openshiftmm/listinfo/users

Reply via email to