Hi Bogdan, It wasnt set aaa_flag ... and now is it. Im trying install freeradius 1.1.3 from tarball ... and when I do make command, this error appears:
.libs/modules.o: In function `setup_modules': /usr/src/freeradius-1.1.3/src/main/modules.c:704: undefined reference to `lt__PROGRAM__LTX_preloaded_symbols' collect2: ld returned 1 exit status make[4]: *** [radiusd] Error 1 make[4]: Leaving directory `/usr/src/freeradius-1.1.3/src/main' make[3]: *** [common] Error 2 make[3]: Leaving directory `/usr/src/freeradius-1.1.3/src' make[2]: *** [all] Error 2 make[2]: Leaving directory `/usr/src/freeradius-1.1.3/src' make[1]: *** [common] Error 2 make[1]: Leaving directory `/usr/src/freeradius-1.1.3' make: *** [all] Error 2 If i use debian freeradius package... this errors appears: Tue Dec 18 16:35:13 2012 : Error: /etc/freeradius/sql.conf[21]: Instantiation failed for module "sql" Tue Dec 18 16:35:13 2012 : Error: /etc/freeradius/radiusd.conf[765]: Failed to load module "sql". Tue Dec 18 16:35:13 2012 : Error: /etc/freeradius/radiusd.conf[763]: Errors parsing accounting section. Tue Dec 18 16:35:13 2012 : Error: Failed to load virtual server <default> Any help? Willian Mazzardo Depto TI - SYSSVOIP www.syssvoip.com.br 55 3537 2030 2012/12/18 Bogdan-Andrei Iancu <[email protected]> > ** > Are you configuring and using in script the aaa_flag ( > http://www.opensips.org/html/docs/modules/1.8.x/acc.html#id292429) ? > > Regards, > > Bogdan-Andrei Iancu > OpenSIPS Founder and Developerhttp://www.opensips-solutions.com > > > On 12/18/2012 04:09 PM, Willian Mazzardo - SYSSVOIP wrote: > > I have made some adjusts in freeradius and radiusclient-ng files... and my > acc module on opensips.cfg is: > > modparam("aaa_radius", "radius_config", > "/etc/radiusclient-ng/client.conf") > modparam("acc", "aaa_url", > "radius:/etc/radiusclient-ng/radiusclient.conf") > modparam("acc", "aaa_extra", "via=$hdr(Via[*]); email=$avp(s:email); > Bcontact=$ct / reply") > > Need I put something in route script? > > > Thanks > > Willian Mazzardo > Depto TI - SYSSVOIP > www.syssvoip.com.br > 55 3537 2030 > > > > 2012/12/18 Willian Mazzardo - SYSSVOIP <[email protected]> > >> Ok. I will do that. >> >> Thanks >> Em 18/12/2012 05:06, "Bogdan-Andrei Iancu" <[email protected]> >> escreveu: >> >> Take a look at http://www.opensips.org/Resources/DocsTutRadius >>> >>> And be sure first that OpenSIPS (properly configured) is sending the ACC >>> request to the RADIUS server. >>> >>> Regards, >>> >>> Bogdan-Andrei Iancu >>> OpenSIPS Founder and Developerhttp://www.opensips-solutions.com >>> >>> >>> On 12/18/2012 03:58 AM, Willian Mazzardo - SYSSVOIP wrote: >>> >>> Yes... I follow the tutorial in CDR tool website. >>> >>> There is any way to check if everything is ok? >>> >>> Thanks >>> It might be a silly question, but have you configured the accounting >>> via radius backend ? >>> >>> Regards, >>> >>> Bogdan-Andrei Iancu >>> OpenSIPS Founder and Developerhttp://www.opensips-solutions.com >>> >>> >>> On 12/17/2012 11:49 PM, Willian Mazzardo - SYSSVOIP wrote: >>> >>> OK ... I have made some tests and now I`m able to use Dialplan module on >>> Opensips-cp ... and are working good. >>> >>> Now i`m trying make work CDRTool on this scenario ... but no luck ... >>> cdrtool daemon is running, freeradius too ... but no data on radacct201212 >>> table on radius database. >>> >>> How can I debug cdrtool to see what is going on? >>> >>> Thanks >>> >>> >>> Willian Mazzardo >>> Depto TI - SYSSVOIP >>> www.syssvoip.com.br >>> 55 3537 2030 >>> >>> >>> >>> 2012/12/17 Bogdan-Andrei Iancu <[email protected]> >>> >>>> Hi Willian, >>>> >>>> Assuming that route(3) is doing routing to register subscribers and >>>> route(5) is doing routing to PSTN and inside these routes you do the >>>> t_relay(), I would suggest moving the setflag for accounting before >>>> triggering those routes. The main idea is to have the setflag done before >>>> the call is forwarded to whatever destination. >>>> >>>> Regards, >>>> >>>> Bogdan-Andrei Iancu >>>> OpenSIPS Founder and Developerhttp://www.opensips-solutions.com >>>> >>>> >>>> On 12/17/2012 08:19 PM, Willian Mazzardo - SYSSVOIP wrote: >>>> >>>> Hi Bogdan ... sorry for this ... >>>> >>>> I've initiated some tests with Opensips ... and almost everything is >>>> working ... >>>> >>>> Now, i`m trying do a separate route for internal accounts calls and >>>> PSTN calls. >>>> >>>> I`ve this script on INVITE: >>>> >>>> if (is_method("INVITE")) { >>>> >>>> if(uri=~"^sip:[55910][0-9][0-9][0-9][0-9]@*") { >>>> xlog("Willian: passou por aqui PONTO A PONTO"); >>>> route(3); >>>> >>>> setflag(1); # do accounting >>>> >>>> }else{ >>>> >>>> xlog("Willian: passou por aqui SAIDA"); >>>> >>>> rewritehostport("177.126.178.106:5060"); >>>> route(5); >>>> >>>> setflag(1); # do accounting >>>> >>>> } >>>> >>>> setflag(1); # do accounting >>>> } >>>> >>>> My internal accounts start with 55910XXXX and my PSTN calls are >>>> Country Code + Region Code ... like for Brazil = 555588889999 >>>> >>>> Is this INVITE section right? >>>> >>>> Thanks. >>>> >>>> >>>> >>>> Willian Mazzardo >>>> Depto TI - SYSSVOIP >>>> www.syssvoip.com.br >>>> 55 3537 2030 <55%203537%202030> >>>> >>>> >>>> >>>> 2012/12/15 Bogdan-Andrei Iancu <[email protected]> >>>> >>>>> Hi, >>>>> >>>>> This is a mailing list for opensips project, and we do offer support >>>>> and help for opensips. So either you redirect your question to the right >>>>> mailing list, either you start using opensips >>>>> >>>>> Regards, >>>>> Bogdan >>>>> >>>>> >>>>> Sent from Samsung Mobile >>>>> >>>>> Willian Mazzardo - SYSSVOIP <[email protected]> wrote: >>>>> Hi all.. >>>>> >>>>> I`m a very new user coming from Asterisk, and I want to do some test >>>>> with Kamailio billing / cdr my calls. >>>>> >>>>> I have installed CDRTool and Kamailio with a working cfg who route >>>>> any call to my SIP Provider. >>>>> >>>>> But, when I do some call and hang up later... the system doesn't >>>>> create any log into radacct* tables. >>>>> >>>>> I checked every configuration in /etc/cdrtool/global.inc and seems >>>>> to be OK. >>>>> >>>>> I think maybe is an kamailio routing issue, like no flag or >>>>> something. >>>>> >>>>> Can anyone help me with this? >>>>> >>>>> Thanks in advice. >>>>> >>>>> >>>>> Willian Mazzardo >>>>> Depto TI - SYSSVOIP >>>>> www.syssvoip.com.br >>>>> 55 3537 2030 <55%203537%202030> >>>>> >>>>> >>>> >>> >
_______________________________________________ Users mailing list [email protected] http://lists.opensips.org/cgi-bin/mailman/listinfo/users
