I'm a bit confused. The original report was on a record_route() / loose_route() matter. But you say you have opensips as B2B, so the RR mechanism must not be used in such a case- you act either as a end-point, either as a proxy - you cannot be both for the same call.

Now you have this b2b error, during a call transfer scenario. and you mentioned LB also :)...so I'm a bit confused - could please try to put all these pieces together, so I can understand what you are doing?

Regards,

Bogdan-Andrei Iancu

OpenSIPS Founder and Developer
  http://www.opensips-solutions.com
OpenSIPS Summit 2018
  http://www.opensips.org/events/Summit-2018Amsterdam

On 02/02/2018 04:27 PM, Brian Southworth wrote:

Maybe I am doing this wrong but I wanted the B2BUA module to handle the refer and bridge the calls.

I have the B2bUA working now. However my issue is that its not able to send the replies.

incoming reply

b2b_reply (B2B.222.7591351.1517580641)

Feb 2 14:10:47 [22664] ERROR:tm:_reply_light: failed to generate 408 reply when a final 200 was sent out

Feb 2 14:10:47 [22664] ERROR:b2b_entities:b2b_send_reply: failed to send reply with tm

Feb 2 14:10:47 [22664] ERROR:b2b_logic:b2b_logic_notify_reply: Sending reply failed - 408, [B2B.452.342.1517580641]

Do you need anything else to help me debug this ? I am not sure why its failing to pass the reply with tm, I have enabled the param:

modparam("tm","pass_provisional_replies",1)

I should also note that I am using the load balancer module also. This normally deals with all call distribution. In and out.

Regards,

Brian Southworth

*From:*Bogdan-Andrei Iancu [mailto:bog...@opensips.org]
*Sent:* 02 February 2018 14:20
*To:* Brian Southworth <brian.southwo...@clocom.uk>; OpenSIPS users mailling list <users@lists.opensips.org> *Subject:* Re: [OpenSIPS-Users] [15066] WARNING:rr:after_strict: no socket found to match RR [1][XXX.XXX.XXX.XXX:5060]

Hi Brian,

Maybe that warning points to a routing error that prevents the REFER to be route to carrier - make a sip capture to be sure the REFER from A is properly routed and accepted by the carrier.

Regards,

Bogdan-Andrei Iancu
OpenSIPS Founder and Developer
   http://www.opensips-solutions.com
OpenSIPS Summit 2018
   http://www.opensips.org/events/Summit-2018Amsterdam

On 02/02/2018 01:38 PM, Brian Southworth wrote:

    Hi Bogdan,

    Thank you very much, so this doesn’t have any impact on why the
    call being transferred are dropped ?

    I am trying to transfer a call using the refer method as that is
    what the cisco phones use.

    The network is setup like so opensips proxy àasterisk gateway àcarrier

    Scenario:

    Inbound call comes into the phone like so: carrier àast àproxy
    àphone A

    Phone A needs to transfer call to phone B: Phone A dials phone B
    àphone B picks up àphone A presses xfer button and call is dropped.

    Any help would be appreciated.

    Regards,

    Brian Southworth

    *From:*Bogdan-Andrei Iancu [mailto:bog...@opensips.org]
    *Sent:* 02 February 2018 11:29
    *To:* OpenSIPS users mailling list <users@lists.opensips.org>
    <mailto:users@lists.opensips.org>; Brian Southworth
    <brian.southwo...@clocom.uk> <mailto:brian.southwo...@clocom.uk>
    *Subject:* Re: [OpenSIPS-Users] [15066] WARNING:rr:after_strict:
    no socket found to match RR [1][XXX.XXX.XXX.XXX:5060]

    Hi Brian,

    That warning means OpenSIPS found a Route header (while doing
    loose_route) that is suppose to be of its own, but the network
    information from the header does not match any of the OpenSIPS SIP
    listeners.

    Best regards,


    Bogdan-Andrei Iancu

    OpenSIPS Founder and Developer

       http://www.opensips-solutions.com

    OpenSIPS Summit 2018

       http://www.opensips.org/events/Summit-2018Amsterdam

    On 02/02/2018 11:14 AM, Brian Southworth wrote:

        I get this when trying to transfer calls using the B2BUA:

        [15066] WARNING:rr:after_strict: no socket found to match RR
        [1][xxx.xxx.xxx.xxx:5060]

        When I try looking on the mailing list there are no other
        similar posts, could you please shed some light on what maybe
        causing this please.

        Regards,

        Brian Southworth





        _______________________________________________

        Users mailing list

        Users@lists.opensips.org <mailto:Users@lists.opensips.org>

        http://lists.opensips.org/cgi-bin/mailman/listinfo/users


_______________________________________________
Users mailing list
Users@lists.opensips.org
http://lists.opensips.org/cgi-bin/mailman/listinfo/users

Reply via email to