Hi John,

Yes, found the issue - it was introduced by this commit:
https://github.com/OpenSIPS/opensips/commit/7844aaba9400e6480d341c18ac41dcc17b403070
but the carrier ID AVP is by default not set, so the delete op generate the harmless error


It  should be fixed now on all maintained versions.

Thanks and regards,

Bogdan-Andrei Iancu

OpenSIPS Founder and Developer
  http://www.opensips-solutions.com
OpenSIPS Summit 2018
  http://www.opensips.org/events/Summit-2018Amsterdam

On 04/05/2018 01:32 PM, John Quick wrote:
I'm testing with v2.4 beta. Using the DROUTING module.
When I call the function do_routing("2") it always generates the following
error:
ERROR:core:search_first_avp: invalid avp id -1

I've used this module and this function before in earlier versions of
OpenSIPS and I cannot recall seeing this error message before.

I tried various remedies such as adding/removing this line:
modparam("drouting", "ruri_avp", '$avp(dr_ruri)')

..also I have tried both of the following as a way of calling the function:
     if
(do_routing("2",,,"$var(ruleattrs)","$var(gwattrs)","$var(carrattrs)")) {
     if (do_routing("2")) {

but every time I see the same error reported.

By the way, the function operates as expected and selects the correct
gateway. The error message seems to be irrelevant.

John Quick
Smartvox Limited
Web: www.smartvox.co.uk



_______________________________________________
Users mailing list
Users@lists.opensips.org
http://lists.opensips.org/cgi-bin/mailman/listinfo/users


_______________________________________________
Users mailing list
Users@lists.opensips.org
http://lists.opensips.org/cgi-bin/mailman/listinfo/users

Reply via email to