It looks like you are connecting to a single node (which is SECONDARY), rather than a replica set, so the driver is unable to locate a PRIMARY node, to which it can issue writes.

What does your DocumentDB infrastructure look like?  Is it a replica set?  A single instance?

Liviu Chircu
OpenSIPS Developer
http://www.opensips-solutions.com

On 16.09.2019 10:35, Sasmita Panda wrote:
The new core file is given below in pastebin

https://pastebin.com/zMpf12MQ


Rather than this , I was trying to upgrade mongo c library to 1.9 and running with document DB .

Here I am not able to connect to Document DB . its giving below error
When I am connecting with SSL=true
 ERROR:cachedb_mongodb:mongo_con_update: last error: 15.13053: No suitable servers found (`serverSelectionTryOnce` set): [TLS handshake failed: error:1416F086:SSL routines:tls_process_server_certificate:certificate verify failed calling ismaster on 'docdb-2019-09-14-06-14-132.c8aqanvkjwjr.us-east-1.docdb.amazonaws.com:27017 <http://docdb-2019-09-14-06-14-132.c8aqanvkjwjr.us-east-1.docdb.amazonaws.com:27017>']

When I am doing without ssl
ERROR:cachedb_mongodb:mongo_con_update: last error: 1.11: Authentication failed.

In both the cases I am able to connect to the Doc DB from the instance console . But in opensips its giving such error . Opensips is not crashing although .  Why is this error coming . I am not getting this error in the code also .

Below is the library version in my instance . and Document db is in same 3.6 version .
dpkg -l | grep -i libmongoc
ii  libmongoc-1.0-0                      1.9.2+dfsg-1build1                 amd64        MongoDB C client library - runtime files ii  libmongoc-dev                        1.9.2+dfsg-1build1                 amd64        MongoDB C client library - dev files


*/Thanks & Regards/*
/Sasmita Panda/
/Senior Network Testing and Software Engineer/
/3CLogic , ph:07827611765/


On Thu, Sep 12, 2019 at 7:50 PM Liviu Chircu <li...@opensips.org <mailto:li...@opensips.org>> wrote:

    Let's follow the official build guide [1], maybe it will make
    things easier.

    So make sure to install below requirements, then try again:

    sudo apt install cmake libssl-dev libsasl2-dev

    [1]: http://mongoc.org/libmongoc/current/installing.html

    Liviu Chircu
    OpenSIPS Developer
    http://www.opensips-solutions.com

    On 12.09.2019 14:37, Sasmita Panda wrote:
    make[1]: Entering directory '/opt/mongo-c-driver'
      CCLD     test-replica-set
    /usr/bin/ld: tests/test_replica_set-ha-test.o: undefined
    reference to symbol 'pthread_once@@GLIBC_2.2.5
    <mailto:pthread_once@@GLIBC_2.2.5>'
    //lib/x86_64-linux-gnu/libpthread.so.0: error adding symbols: DSO
    missing from command line
    _______________________________________________
    Users mailing list
    Users@lists.opensips.org <mailto:Users@lists.opensips.org>
    http://lists.opensips.org/cgi-bin/mailman/listinfo/users


_______________________________________________
Users mailing list
Users@lists.opensips.org
http://lists.opensips.org/cgi-bin/mailman/listinfo/users
_______________________________________________
Users mailing list
Users@lists.opensips.org
http://lists.opensips.org/cgi-bin/mailman/listinfo/users

Reply via email to