Hi, Sharad!

The problem is that the cc_flows table is empty - you need to populate that table with valid data.

Best regards,
Răzvan

On 1/11/20 3:32 AM, Sharad Kumar via Users wrote:
Hey guys,

I am trying to load call_center module on openSIPS 2.4  but getting a lot of erros. Here is my configuration -
# B2B Module
loadmodule "b2b_entities.so"
loadmodule "b2b_logic.so"
modparam("b2b_logic", "script_scenario", "/usr/local/etc/opensips/scenario_callcenter.xml")

# Call center module
loadmodule "call_center.so"
modparam("call_center", "db_url","mysql://opensipsuser:password@localhost/opensips") # CUSTOMIZE ME #modparam("call_center", "acc_db_url","mysql://password@localhost/opensips") # CUSTOMIZE ME #modparam("b2b_logic", "script_scenario", "/usr/local/etc/opensips/scenario_callcenter.xml")
modparam("call_center", "b2b_scenario", "call center")
modparam("call_center", "wrapup_time", 3)

--------------------------------------------------------------------------------------------------------------


I have tried all combinations but still no luck, I also have db_default_url variable defined. And these are the error logs -

Jan 10 19:29:31 98 /usr/local/sbin/opensips[1617]: INFO:dialplan:mod_init: initializing module... Jan 10 19:29:31 98 mysqld[1393]: 2020-01-10 19:29:31 28 [Warning] Aborted connection 28 to db: 'opensips' user: 'opensipsuser' host: 'localhost' (Got an error reading communication packets) Jan 10 19:29:31 98 /usr/local/sbin/opensips[1617]: INFO:call_center:mod_init: Call Center module - initializing Jan 10 19:29:31 98 /usr/local/sbin/opensips[1617]: WARNING:call_center:cc_load_db_data: table "cc_flows" empty Jan 10 19:29:31 98 /usr/local/sbin/opensips[1617]: CRITICAL:call_center:mod_init: failed to load callcenter data
Jan 10 19:29:31 98 opensips[1599]:  already running.
Jan 10 19:29:31 98 /usr/local/sbin/opensips[1617]: ERROR:core:init_mod: failed to initialize module call_center
Jan 10 19:29:31 98 systemd[1]: Started LSB: Start the OpenSIPS SIP server.
Jan 10 19:29:31 98 /usr/local/sbin/opensips[1617]: ERROR:core:main: error while initializing modules Jan 10 19:29:31 98 /usr/local/sbin/opensips[1617]: INFO:core:cleanup: cleanup Jan 10 19:29:31 98 /usr/local/sbin/opensips[1617]: NOTICE:core:main: Exiting.... Jan 10 19:29:31 98 opensips: INFO:core:daemonize: pre-daemon process exiting with -1

I am thinking that this is mysql related issue or openSIPS bug. I have also adjusted max_allowed_packet=256M on mysql server. Please help.

Thanks and regards


_______________________________________________
Users mailing list
Users@lists.opensips.org
http://lists.opensips.org/cgi-bin/mailman/listinfo/users


--
Răzvan Crainea
OpenSIPS Core Developer
  http://www.opensips-solutions.com

_______________________________________________
Users mailing list
Users@lists.opensips.org
http://lists.opensips.org/cgi-bin/mailman/listinfo/users

Reply via email to