Hello all,

I was finally able to install quantum espresso at /mnt/c/ folder using Kali 

The program is succesfully running.

Bishal Dumre
From: Lorenzo Paulatto <lorenzo.paula...@cnrs.fr>
Sent: Tuesday, March 28, 2023 2:41 AM
To: Quantum ESPRESSO users Forum <users@lists.quantum-espresso.org>; Dumre, 
Bishal Babu B <bishalbabu.du...@rockets.utoledo.edu>; 
users@lists.quantum-espresso.org <users@lists.quantum-espresso.org>
Subject: [EXTERNAL] Re: [QE-users] Problem installing QE in Windows 11 using 
Kali Linux

Kali linux is a distribution specialized for network penetration testing, I 
highly doubt that it is suitable for compiling scientific code. Granted that 
all distributions are the same after you have installed the right package, I 
would recommend you start from a general purpose one.

Kind regards

On March 27, 2023 8:07:27 p.m. GMT+02:00, "Dumre, Bishal Babu B" 
<bishalbabu.du...@rockets.utoledo.edu> wrote:
Hello there,

I am trying to install quantum espresso inside Windows 11. I am using Kali 
linux distribution. I tried using many other distributions but Kali linux was 
better than others. After installing dependencies like git and Fortran, I was 
able to run "./configure" command, but, finally the "make all" command does not 
work. I tried many variations of make all command, but it does not work. The 
details of error is given below:

$ make all
test -d bin || mkdir bin
cd install ; make -f extlibs_makefile libfox
make[1]: Entering directory '/mnt/c/Users/Bishal 
if test ! -d ../FoX ; then \
  cd /mnt/c/Users/ Dumre/Desktop/QuantumEspresso/qe-7.1//external/fox; \
    ./configure --prefix=/mnt/c/Users/ 
Dumre/Desktop/QuantumEspresso/qe-7.1//FoX FC=gfortran FCFLAGS=""; \
    touch cp_test; \
    if cp -p cp_test cp_test_1; then \
        rm cp_test_1; \
        echo "cp -p works"; \
    else \
        find -type f | xargs sed -i 's/cp -p/cp/g'; \
    fi; \
    rm cp_test; \
    make install && make clean; \
 cd -; \
/bin/sh: 3: ./configure: not found
touch: cannot touch 'cp_test': Permission denied
cp: cannot stat 'cp_test': No such file or directory
sed: can't read ./Bishal: No such file or directory
sed: can't read Dumre/.burai/.properties: No such file or directory
sed: can't read ./Bishal: No such file or directory
sed: can't read Dumre/.burai/.pseudopot/.pseudolist: N
Trailing errors of sed: A lot.
sed: can't read Framework/Obligations/CND2023R23.xml: No such file or directory
sed: can't read ./Default/AppData/Local/Microsoft/Internet: No such file or 
sed: can't read Explorer/MSIMGSIZ.DAT: No such file or directory
sed: couldn't open temporary file 
./Default/AppData/Local/Microsoft/Windows/INetCache/IE/sedoEwhLu: Permission 
rm: cannot remove 'cp_test': No such file or directory
make[2]: Entering directory '/mnt/c/Users'
make[2]: *** No rule to make target 'install'.  Stop.
make[2]: Leaving directory '/mnt/c/Users'
/mnt/c/Users/Bishal Dumre/Desktop/QuantumEspresso/qe-7.1/install
make[1]: Leaving directory '/mnt/c/Users/Bishal 
( cd UtilXlib ; make TLDEPS= all || exit 1 )
make[1]: Entering directory '/mnt/c/Users/Bishal 
Makefile:49: make.depend: No such file or directory
make[1]: *** No rule to make target 'make.depend'.  Stop.
make[1]: Leaving directory '/mnt/c/Users/Bishal 
make: *** [Makefile:209: libutil] Error 1

Please help me.

Bishal Dumre
The Quantum ESPRESSO community stands by the Ukrainian
people and expresses its concerns about the devastating
effects that the Russian military offensive has on their
country and on the free and peaceful scientific, cultural,
and economic cooperation amongst peoples
Quantum ESPRESSO is supported by MaX (www.max-centre.eu)
users mailing list users@lists.quantum-espresso.org

Reply via email to