If it's happening immediately upon trying to import the template, I believe
that's the error message saying that the 1.9 instance cannot find the NAR
file which provided the processor. Also, if you're referring to 1.9.0 and
not 1.9.2 you're going to want to upgrade to the latter because there are a
few critical bugs fixed in 1.9.2.

On Wed, Aug 7, 2019 at 9:19 PM Bimal Mehta <bimal...@gmail.com> wrote:

> Thanks Bryan.
> My custom processors are part of a template. However when I try to import
> my template in NiFi 1.9, I get an error message saying
> PutFeedMetadata is not known to this NiFi instance. I did update all the
> dependencies to NiFi 1.9 and even the plugins. We are using a Cloudera
> distributed version of NiFi 1.9.
> Any idea why is this happening?
>
> Thanks
>
>
>
> On Wed, Aug 7, 2019 at 3:46 PM Bryan Bende <bbe...@gmail.com> wrote:
>
>> Hello,
>>
>> Most likely your processor built against 1.6 would run fine in 1.9,
>> but to make sure you just need to update any nifi dependencies in your
>> poms to 1.9.2.
>>
>> If you created your project from the archetype and didn't change
>> anything, then this should just be changing the parent in the root pom
>> to the new version of nifi-nar-bundles.
>>
>> If you set it up yourself, then anywhere you depend on nifi-api you
>> need to change.
>>
>> -Bryan
>>
>> On Wed, Aug 7, 2019 at 3:18 PM Bimal Mehta <bimal...@gmail.com> wrote:
>> >
>> > Hi,
>> >
>> > If we have a custom processor that was created with NiFi 1.6, what are
>> the steps we need to follow to make it work in 1.9?
>> > Is there some sort of steps that explains the jar and pom updates we
>> need to do for making it work in 1.9?
>>
>

Reply via email to