Hi,

from the top of my head you could try to play with tuned both with guest and 
host

###Install###
 yum install tuned
 /etc/init.d/tuned start
 chkconfig tuned on

###usage###
list the profile:
 tuned-adm list

change your profile:
tuned-adm profile throughput-performance

maybe try to experiment with other profiles.

HTH

Martin Pavlik
RHEV QE

> On 14 Jan 2015, at 12:06, mad Engineer <themadengin...@gmail.com> wrote:
> 
> I am running RHEL6.5 as Host and Guest on HP server.
> Server has 128G and 48 Core[with HT enabled.]
> 
> 3 VMs are running 2 pinned to first 24 PCPU with proper NUMA pinning,
> 
> Guests:
> 
> VM1:
> 6 VCPU  pinned to 6 PCPU NUMA node 1,with 16G RAM
> 
> VM2:
> 6 VCPU pinned to 6 PCPU on NUMA node 0,with 16G RAM
> 
> VM3:
> 2 VCPU ,no pinning,4G RAM
> 
> HOST
> host has 10 free CPU+24 HT threads which is not allocated and is available.
> Host also runs a small application that is single threaded,that uses ~4G RAM.
> 
> Total resource to host is 10 CPU+24 HT=34 and 92G unallocated RAM[VMS
> dont even use 70% of allocated RAM] also ksm is not running.
> 
> Networking:
> Uses linux bridge connected to 1Gbps eth0,with ip assigned on eth0
> [This IP is called for accessing application running on host]
> All vms use virtio and VHOST is on .
> 
> Traffic on virtual machines are ~3MBps and combined traffic on host is ~14MBps
> 
> "VHOST-pid-of-qemu-process" sometimes uses ~35% CPU.
> 
> 
> There is no packet loss,drop or latency,but the issue is with the same
> setup on Vmware with same sizing of virtual machines,with the only
> difference as application running on host has moved to fourth VM.So in
> Vmware there are 4 VMs.
> Application gives better number ie on KVM that number is 310 and on
> vmware it is 570.Application uses UDP to communicate.
> 
> I tried removing VHOST,still value is same.(I hope VHOST-NET UDP issue
> is solved)
> 
> Thanks for any help
> _______________________________________________
> Users mailing list
> Users@ovirt.org
> http://lists.ovirt.org/mailman/listinfo/users

_______________________________________________
Users mailing list
Users@ovirt.org
http://lists.ovirt.org/mailman/listinfo/users

Reply via email to