On 20/01/15 09:30, Lars Nielsen wrote:

On 20/01/15 09:09, Martin Pavlík wrote:
ccing Carlos as he might be able to help

Hi Lars,

1) remove as many restrictions as you can from your NFS export , allow all to access and restrict it back step by step if removing restriction will work 2) make sure that exported folders have owner and group vdsm:kvm (aka 36:36) 3) pls check (and provide) /var/log/vdsm/vdsm.log and /var/log/vdsm/supervdsm.log on the hypervisor which is storage pool manager (aka SPM), you can identify it on hosts tab in GUI


On 20 Jan 2015, at 08:51, Lars Nielsen <l...@steinwurf.com> wrote:

On 15/01/15 16:38, Donny Davis wrote:
Also check to see if there are any directories that have been created in
your nfs exports


-----Original Message-----
From: users-boun...@ovirt.org [mailto:users-boun...@ovirt.org] On Behalf Of
Martin Pavlík
Sent: Thursday, January 15, 2015 8:01 AM
To: Lars Nielsen
Cc: users@ovirt.org
Subject: Re: [ovirt-users] problem adding storage connection

Hi Lars,

are you sure you want to use net mask IMO you want to use

If it does not help please supply logs
/var/log/ovirt-engine/engine.log - from engine node (RHEV-M) and

so we can see detailed error message


Martin Pavlik

On 15 Jan 2015, at 14:22, Lars Nielsen <l...@steinwurf.com> wrote:

Hello again.
And thanks for the help, now I can create hosts, which run :)

However I have run into a bit more trouble, again which seems a bit
strange to me.
When trying to added a new Storage connection, I get this:
Error while executing action: Cannot add Storage Connection. Storage
connection already exists.

My exports file, look like this:
d=36,anongid=36) /home/data,sync,no_subtree_check,all_squash,anonui
d=36,anongid=36) /home/import_data,sync,no_subtree_check,all_squash,anonui

Copied from the oVirt basic setup guide.
And I have restarted my NFS server service, and create the directories.

Can some one help with this? and explain the problem to me? If you need
more info, please tell me.
Thanks and Best Regards
- Lars
Users mailing list
Users mailing list

I tried fixing it by changing to to no avail.
So please help me again, I have looked through logs, and found this:
015-01-20 08:40:14,177 INFO [org.ovirt.engine.core.dal.dbbroker.auditloghandling.AuditLogDirector] (ajp-- Correlation ID: null, Call Stack: null, Custom Event ID: -1, Message: User admin logged in. 2015-01-20 08:40:14,226 INFO [org.ovirt.engine.core.bll.aaa.LoginUserCommand] (ajp-- Running command: LoginUserCommand internal: false. 2015-01-20 08:41:04,709 INFO [org.ovirt.engine.core.bll.storage.AddStorageServerConnectionCommand] (ajp-- [27222a90] Lock Acquired to object EngineLock [exclusiveLocks= key: value: STORAGE_CONNECTION
, sharedLocks= ]
2015-01-20 08:41:04,711 WARN [org.ovirt.engine.core.bll.storage.AddStorageServerConnectionCommand] (ajp-- [27222a90] CanDoAction of action AddStorageServerConnection failed. Reasons:VAR__ACTION__ADD,VAR__TYPE__STORAGE__CONNECTION,ACTION_TYPE_FAILED_STORAGE_CONNECTION_ALREADY_EXISTS 2015-01-20 08:41:04,711 INFO [org.ovirt.engine.core.bll.storage.AddStorageServerConnectionCommand] (ajp-- [27222a90] Lock freed to object EngineLock [exclusiveLocks= key: value: STORAGE_CONNECTION
, sharedLocks= ]

But I am not really sure what to do, to fix it :) The complete oVirt log folder can be found here:

Thanks and Best Regards
- Lars
I have removed the restrictions. Still no loot.
The logs for oVirt and VDSM https://dl.dropboxusercontent.com/u/55488/documents-export-2015-01-20.zip

Really no one has an explanation ? :(

Med venlig hilsen / Best Regards
Lars Nielsen
Student developer at Steinwurf

Users mailing list

Reply via email to