somehow guest pxe booting stopped working for me. PXE boot fails on getting ip via dhcp with error 'connection timed out' and i cannot find any reason why... In first few seconds of VM's life it actually manages to send some network packets - I can see dhcp request on dhcp server, I even see a dhcp reply on both host's network interface and vm's vnetX interface. However, gpxe still says "connection timeout". During this "first time" i also can see some network traffic via tcpdump on vnetX interface (some arp's, multicasts, etc from other vms) But after a while - all activity on vnetX interface ceases, no packets at all, no dhcp requests from VM, no replies, no arp - nothing at all. Also what caught my eye - 'brctl showmacs <bridgename>' doesn't show VM's MAC at all, it lists it only after OS is booted. And same behaviour with any nic driver - virtio/e1000/rtl However, once VM is booted (if cloned, or imported via glance, or installed from CD) - network works just fine, no problems with dhcp/arp or anything else.

I tried to re-create VM, tried to add/remove/change vm nic's, tried to change MAC, tried to restart vdsm and engine, tried to start vm on different hosts - nothing helps. The only recent change in my environment were update ovirt-3.4.3 -> ovirt-3.4.4.
Please, tell me what went wrong?

ovirt 3.4.4-el6, hosts on centos 6.6, guests - centos 6.6

Yuriy Demchenko

Users mailing list

Reply via email to