I have setup an environment with 8 glustefs nodes in distributed+replicated mode. Instead of CTDB, I'm using keepalived. It works pretty well.

On 02/04/2015 04:14 PM, Donny Davis wrote:

I have two nodes running the hosted engine and gluster setup for replicate between them. Mounting to localhost seems to be working so far. I have live migrated the engine, pulled the plug on a running node, and rebooted each node to ensure it all works properly. I have had few issues with this setup. I didn’t like ctdb because it adds another layer of complexity that is unnecessary for MY setup.

Node1 gluster drive on sdb

Node2 gluster drive on sdb

Both replicate and are the same make and model drive.

ovirt-ha running on both for hosted-engine

This setup is for hosted engine only, my actual storage for VM’s and what not do not run in this fashion.

Hope This helps

Donny D

*From:*users-boun...@ovirt.org [mailto:users-boun...@ovirt.org] *On Behalf Of *Groten, Ryan
*Sent:* Wednesday, February 4, 2015 10:11 AM
*To:* Sahina Bose; users@ovirt.org
*Subject:* Re: [ovirt-users] Help understanding Gluster in oVirt

Nope in fact I followed the guide and found CTDB works quite well. I am just trying to figure out the benefit because that would be another component to consider in the architecture.

*From:*Sahina Bose [mailto:sab...@redhat.com]
*Sent:* Tuesday, February 03, 2015 4:09 AM
*To:* Groten, Ryan; users@ovirt.org <mailto:users@ovirt.org>
*Subject:* Re: [ovirt-users] Help understanding Gluster in oVirt

On 01/28/2015 08:59 AM, Groten, Ryan wrote:

    I was planning on making a Gluster Data domain to test, and found
    some great information on this page:
    http://community.redhat.com/blog/2014/05/ovirt-3-4-glusterized/

    The article the author uses the CTDB service for VIP failover.  Is
    it possible/recommended to not do this, and just create a gluster
    volume on all the hosts in a cluster, then create the Gluster data
    domain as localhost:<gluster_vol>?


Theoretically, it should work - if you make sure that you have a replica 3 gluster volume spread across 3 nodes, and these 3 nodes are your compute nodes as well - you should be fine without CTDB setup for failover and mounting as localhost.

But I've not tried this to recommend it. Maybe if others have tried it, they can chime in?

Btw, is there any reason you do not want to set up CTDB?

Thanks,

Ryan

ThTh

_______________________________________________
Users mailing list
Users@ovirt.org  <mailto:Users@ovirt.org>
http://lists.ovirt.org/mailman/listinfo/users



_______________________________________________
Users mailing list
Users@ovirt.org
http://lists.ovirt.org/mailman/listinfo/users

_______________________________________________
Users mailing list
Users@ovirt.org
http://lists.ovirt.org/mailman/listinfo/users

Reply via email to