On Thu, Oct 22, 2015 at 3:01 PM, Simone Tiraboschi <stira...@redhat.com>
wrote:

>
>>
>> Any particular file or section in log files to cross check?
>> I can also start from scratch in case.... just to be sure that I don't
>> get into same problem, so that it can be useful to find it before...
>>
>>
> I suspect that that host-deploy fails cause you have in place a leftover
> VDSM cert from the previous attempt which is still signed by your previous
> attempt engine and so it fails to match this new engine: on the second
> attempt hosted-engine-setup deployed again the engine appliance creating a
> new instance with different certs.
>
>
I decided to restart clean and in fact all went well.
Last lines of output of "hosted-engine --deploy"

...
[ INFO  ] Connecting to the Engine
[ INFO  ] Waiting for the host to become operational in the engine. This
may take several minutes...
[ INFO  ] Still waiting for VDSM host to become operational...
[ INFO  ] The VDSM Host is now operational
[ INFO  ] Saving hosted-engine configuration on the shared storage domain
[ INFO  ] Shutting down the engine VM
[ INFO  ] Enabling and starting HA services
          Hosted Engine successfully set up
[ INFO  ] Stage: Clean up
[ INFO  ] Generating answer file
'/var/lib/ovirt-hosted-engine-setup/answers/answers-20151022160359.conf'
[ INFO  ] Generating answer file '/etc/ovirt-hosted-engine/answers.conf'
[ INFO  ] Stage: Pre-termination
[ INFO  ] Stage: Termination

engine is up and admin web portal accessible and host results up.

I expected storage to be configured inside admin web portal but apparently
I don't see anything already configured and also I don't see the sh engine
VM listed... is it correct?

Filesystem layout at this time on the hypervisor is this:
[root@ovc71 tmp]# df -h
Filesystem                           Size  Used Avail Use% Mounted on
/dev/mapper/centos-root               27G  2.7G   24G  11% /
devtmpfs                             3.9G     0  3.9G   0% /dev
tmpfs                                3.9G  4.0K  3.9G   1% /dev/shm
tmpfs                                3.9G  8.7M  3.9G   1% /run
tmpfs                                3.9G     0  3.9G   0% /sys/fs/cgroup
/dev/sda1                            497M  130M  368M  27% /boot
/dev/mapper/OVIRT_DOMAIN-ISO_DOMAIN  5.0G   33M  5.0G   1% /ISO_DOMAIN
/dev/mapper/OVIRT_DOMAIN-NFS_DOMAIN   45G  2.7G   43G   6% /NFS_DOMAIN
ovc71.localdomain.local:/NFS_DOMAIN   45G  2.7G   43G   6%
/rhev/data-center/mnt/ovc71.localdomain.local:_NFS__DOMAIN
/dev/loop1                           2.0G  3.1M  1.9G   1%
/rhev/data-center/mnt/_var_lib_ovirt-hosted-engine-setup_tmpUEso__Q

BTW: what is the 2Gb file system on loop device?

I configured the storage domain part as NFS, pointing
to ovc71.localdomain.local:/NFS_DOMAIN
Reading page at
http://www.ovirt.org/Features/Self_Hosted_Engine

it is not clear to me what to do next if I want for example keep a single
host with its sh engine as a replacement concept of what before was
all-in-one... and start creating VMs....

Output of my web admin page:
https://drive.google.com/file/d/0BwoPbcrMv8mva3UyMTFDbHdsN3c/view?usp=sharing

Also, I didn't restart my hypervisor yet.
WHat should be the shutdown procedure? SImply run shutdown on hypervisor or
1) shutdwn engine vm
2) shutdown hypervisor
?


Gianluca
_______________________________________________
Users mailing list
Users@ovirt.org
http://lists.ovirt.org/mailman/listinfo/users

Reply via email to