On Thu, Nov 12, 2015 at 08:03:05AM +0000, Paul Groeneweg | Pazion wrote:
> I have finished the upgrade to 3.6.

Can you describe how you've performed the upgrade? Did you upgrade
Engine first and then all the hosts (it is highly recommended to upgrade
host one at a time, and move each to maintenance mode before doing so)?
When did the troubling log appeared?

> I received a lot (every 3 seconds ) of the following messages in the
> logs after upgrading the hosts:
>
>  vdsm jsonrpc.JsonRpcServer ERROR Internal server error#012Traceback (most
> recent call last):#012  File
> "/usr/lib/python2.6/site-packages/yajsonrpc/__init__.py", line 501, in
> _serveRequest#012    res = method(**params)#012  File
> "/usr/share/vdsm/rpc/Bridge.py", line 291, in _dynamicMethod#012    return
> self._fixupRet(className, methodName, ret)#012  File
> "/usr/share/vdsm/rpc/Bridge.py", line 235, in _fixupRet#012
>  self._typeFixup('return', retType, result)#012  File
> "/usr/share/vdsm/rpc/Bridge.py", line 215, in _typeFixup#012    if k in
> item:#012TypeError: argument of type 'NoneType' is not iterable
>
> I restarted ovirt-ha-agent ovirt-ha-broker and vdsmd.
> After I rebooted all hosts ( migrating VMS from one to another ) the
> message finally disappeared.

Can you share your vdsm.log of that time? I wish to understand what
method has failed.

>
> Then I tried to set compatibility Version to 3.6, but without luck. I have
> put hosted engine back in global maintenance, but I can't find out why it
> fails. The message says "Error while executing action: Cannot change
> Cluster Compatibility Version to higher version when there are active Hosts
> with lower version.
> -Please move Hosts with lower version to maintenance first."

Can you iterate over your hosts to find which is the culprit?
Then you can move it to maintenance.

> 
> I have installed ovirt-release36 on hosted engine and hosts.
> I have updated hosted engine with engine-setup.
> I ran yum update on all hosts.
> What do I need to do to set compatibility version to 3.6?
> 
> And how can I enable repository for hosted engine? ( through WEB UI change
> is not saved ).


_______________________________________________
Users mailing list
Users@ovirt.org
http://lists.ovirt.org/mailman/listinfo/users

Reply via email to