My POC environment have 2 hosts - host A and host B, both are CentOS7. 
Installed oVirt 3.6 self-hosted engine. I manually created a 2-brick 
GlusterFS volume using both hosts and added it to my datacenter.

I tried shutting down host A. The hosted-engine restarted in host B 
within 3 minutes, which is very cool. However, the GlusterFS data 
domain, which I set both 'Use Host' and 'Path' to the host A, is down 
along with it.

Here comes my questions:
1. How can I enable failover GlusterFS data domain?
2. How can I reverse back to the state before adding the data domain? 
The data domain is super persistent - I can't edit or delete it. I put 
it to maintenance mode but still unable to detach or destroy it because 
it requires me to remove the datacenter first. I tried but can't remove 
the datacenter either.
3. Why can't I add another GlusterFS data domain? When I choose 
'GlusterFS' as my 'Storage Type' every text field become grayed-out.
4. When host A restarted again, I notice that 'Use Host' was changed 
from host A to host B instead. Is this an expected behavior?

Wee Sritippho

P.S: Please excuse my poor English.
Users mailing list

Reply via email to