On Fri, Apr 22, 2016 at 9:46 AM, Simone Tiraboschi <stira...@redhat.com> wrote:
> On Fri, Apr 22, 2016 at 9:44 AM, Wee Sritippho <we...@forest.go.th> wrote:
>> Hi,
>>
>> I were upgrading oVirt from 3.6.4.1 to 3.6.5. The engine-vm was running on
>> host02. These are the steps that I've done:
>>
>> 1. Set hosted engine maintenance mode to global
>> 2. Accessed engine-vm and upgraded oVirt to latest version
>> 3. Run 'reboot' in engine-vm
>> 4. After about 10 minutes, the engine-vm still doesn't boot, so I set hosted
>> engine maintenance mode back to none.
>
> This is absolutely normal: in global maintenance mode the agent will
> not bring up the VM.
>
>> 5. After another 10 minutes, the engine-vm still doesn't boot, so I
>> restarted host02, host01 then host03 before the engine-vm would be
>> accessible again. I then have to activate host01 and host03 again.
>
> This instead is pretty strange: exiting the maintenance mode an host
> should bring up the engine VM.

OK,
it didn't start on host02 since it was in local maintenance mode:
MainThread::INFO::2016-04-23
01:08:12,597::hosted_engine::462::ovirt_hosted_engine_ha.agent.hosted_engine.HostedEngine::(start_monitoring)
Current state LocalMaintenance (score: 0)

The issue on host01 is here:

MainThread::INFO::2016-04-23
01:22:14,608::brokerlink::111::ovirt_hosted_engine_ha.lib.brokerlink.BrokerLink::(notify)
Trying: notify time=1461349334.61 type=state_transition
detail=GlobalMaintenance-ReinitializeFSM
hostname='host01.ovirt.forest.go.th'
MainThread::ERROR::2016-04-23
01:22:44,638::brokerlink::279::ovirt_hosted_engine_ha.lib.brokerlink.BrokerLink::(_communicate)
Connection closed: Connection timed out

The agent failed talking with the broker service (can you please also
attach broker logs from host01?).
Rebooting the host simply restarted also the broker and so the engine
VM went up.
No the issue is why the broker went down and didn't restarted.


>> Here are the log files from ovirt-hosted-engine-ha folder:
>>   - host01: https://gist.github.com/weeix/d73aa8506b296c27110747464ea33312
>>   - host02: https://gist.github.com/weeix/c1b7033f07fb104fdd483cf7ea3a7852
>>
>> How to correctly restart the engine-vm when we need to?
>>
>> --
>> Wee
>>
>> _______________________________________________
>> Users mailing list
>> Users@ovirt.org
>> http://lists.ovirt.org/mailman/listinfo/users
_______________________________________________
Users mailing list
Users@ovirt.org
http://lists.ovirt.org/mailman/listinfo/users

Reply via email to